summaryrefslogtreecommitdiff
path: root/common.mk
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-15 17:10:59 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-15 18:02:55 -0600
commit7b32b8e5eb7cdc8939042ab665f1b80f03036132 (patch)
treeaf4739cb2ce2cfced5947fe3ad09f35fe51bb25f /common.mk
parent5a1241643d4360fa8acc5a1bb9dfbd4a5c691c49 (diff)
Makefiles: pull the config section into config.mk
Diffstat (limited to 'common.mk')
-rw-r--r--common.mk19
1 files changed, 2 insertions, 17 deletions
diff --git a/common.mk b/common.mk
index ef96ee6..bbb1b7c 100644
--- a/common.mk
+++ b/common.mk
@@ -1,20 +1,5 @@
-# Configuration
-DESTDIR=
-
-#prefix=/usr/local
-prefix=/usr
-exec_prefix=$(prefix)
-bindir=$(exec_prefix)/bin
-sbindir=$(exec_prefix)/sbin
-#libexecdir=$(exec_prefix)/libexec
-libexecdir=$(exec_prefix)/lib
-
-datarootdir=$(prefix)/share
-datadir=$(datarootdir)
-#sysconfdir=$(prefix)/etc
-sysconfdir=/etc
-
-docdir=$(datarootdir)/doc
+topdir := $(dir $(lastword $(MAKEFILE_LIST)))
+include $(topdir)/config.mk
################################################################################
progs = $(shell find . -maxdepth 1 -type f -executable -printf '%f\n')