summaryrefslogtreecommitdiff
path: root/common.mk
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-02-02 20:22:24 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-02-02 20:22:24 -0500
commit804e5e1093c3aa8258bf9f8c97ff661cdf8407f1 (patch)
tree3da603d7b28eeb3ba6da52fc857272152c705dfb /common.mk
parente4ccc15cccf46e6265347f4fdee598b0561c4c74 (diff)
Makefiles: use .DELETE_ON_ERROR:
Diffstat (limited to 'common.mk')
-rw-r--r--common.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/common.mk b/common.mk
index ea89de1..deb64c7 100644
--- a/common.mk
+++ b/common.mk
@@ -81,8 +81,8 @@ build: PHONY $(build_files)
ronn --html $(RONNFLAGS) < '$<' > '$@'
%: %.in
@echo "GEN $@"
- @$(edit) <"$<" >"$@" || { rm -f -- '$@'; false; }
- @chmod 755 "$@" || { rm -f -- '$@'; false; }
+ @$(edit) <"$<" >"$@"
+ @chmod 755 "$@"
# Build ########################################################################
@@ -146,3 +146,5 @@ clean-hook: PHONY
FORCE: PHONY
PHONY:
.PHONY: FORCE PHONY
+
+.DELETE_ON_ERROR: