summaryrefslogtreecommitdiff
path: root/common.mk
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-03-22 18:35:00 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-03-22 18:35:00 -0400
commitaaae256525d07aff8d83d4b8ec6332bfd2bb21eb (patch)
treea84ac84c5cbe9d9ff0036ceff7d16fdcfc7c7dd6 /common.mk
parent9c0e1f70df2de45b6b4d0525b64f517ff2533e1b (diff)
Makefiles: inhibit emacs from creating *~ files when formatting a file
Diffstat (limited to 'common.mk')
-rw-r--r--common.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/common.mk b/common.mk
index ec8135f..58366d7 100644
--- a/common.mk
+++ b/common.mk
@@ -13,6 +13,7 @@ edit = sed -e 's|m4_include(lib/\(.*\))|. $$(librelib \1)|'
# Usage: $(call indent,FILENAME)
# Command to auto-indent a file.
indent = emacs --batch $1 \
+ --eval '(setq make-backup-files nil)' \
--eval '(setq sh-basic-offset 8)' \
--eval '(indent-region (point-min) (point-max) nil)' \
-f save-buffer &>/dev/null
@@ -60,7 +61,7 @@ install_files += $(addprefix $(DESTDIR)$(bindir)/,$(progs)) \
$(addprefix $(DESTDIR)$(mandir)/man6/,$(filter %.6,$(mans))) \
$(addprefix $(DESTDIR)$(mandir)/man7/,$(filter %.7,$(mans))) \
$(addprefix $(DESTDIR)$(mandir)/man8/,$(filter %.8,$(mans)))
-clean_files += $(patsubst %.in,%,$(copy_files)) $(copy_files) $(mans) $(wildcard *.pot *.ugly* *~)
+clean_files += $(patsubst %.in,%,$(copy_files)) $(copy_files) $(mans) $(wildcard *.pot *.ugly*)
pots += $(filter-out $(no-pots) ,$(progs))
pot_files += $(addsuffix .pot,$(pots))