summaryrefslogtreecommitdiff
path: root/common.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-01-04 13:52:21 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-01-04 13:52:21 -0500
commit2ef8b28334f0f69caf4bec4ecc68fdd85802c185 (patch)
tree66dedc0bc5ddab027c1a8debc3fc94f3ae3ebf7b /common.mk
parentdf2f833665d56f55dfe04045248f1a38b83cb3fd (diff)
Wow, I botched some Makefile stuff
Diffstat (limited to 'common.mk')
-rw-r--r--common.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/common.mk b/common.mk
index 3a16cf4..53be7cc 100644
--- a/common.mk
+++ b/common.mk
@@ -55,7 +55,7 @@ install_files += $(addprefix $(DESTDIR)$(bindir)/,$(progs)) \
$(addprefix $(DESTDIR)$(mandir)/man6/,$(filter %.6,$(mans))) \
$(addprefix $(DESTDIR)$(mandir)/man7/,$(filter %.7,$(mans))) \
$(addprefix $(DESTDIR)$(mandir)/man8/,$(filter %.8,$(mans)))
-clean_files += $(patsubst %.in,%,$(copy_files)) $(copy_files) $(mans) $(wildcard *.pot *.ugly*)
+clean_files += $(patsubst %.in,%,$(copy_files) $(wildcard *.in)) $(copy_files) $(mans) $(wildcard *.pot *.ugly*)
pots += $(filter-out $(no-pots) ,$(sort $(progs) $(libexecs) $(libs)))
pot_files += $(addsuffix .pot,$(pots))
@@ -97,11 +97,10 @@ $(sort $(_do_patch)): %: %.ugly Makefile
# $(devtoolsdir)/%.in -> %.in -> %
%: %.in
@echo 'EDIT < $< > $@'; $(edit) <"$<" >"$@"
- $(if $(filter-out %.sh,$@),chmod 755 "$@")
+ $(if $(filter $@,$(progs) $(libexecs)),chmod 755 "$@")
# work-around for what I currently believe to be a regression in Make
%.sh: %.sh.in
@echo 'EDIT < $< > $@'; $(edit) <"$<" >"$@"
- $(if $(filter-out %.sh,$@),chmod 755 "$@")
# Build ########################################################################