summaryrefslogtreecommitdiff
path: root/common.top.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-06-29 00:43:52 -0600
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-06-29 00:43:52 -0600
commit30e4649c2642351870914985be2b4f1e40bcd83f (patch)
tree92f8d5b5ae662b511e409abe31381af5d630354f /common.top.mk
(rvs) Start re-jiggering RVS.
Diffstat (limited to 'common.top.mk')
-rw-r--r--common.top.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/common.top.mk b/common.top.mk
new file mode 100644
index 0000000..931bc84
--- /dev/null
+++ b/common.top.mk
@@ -0,0 +1,47 @@
+# Copyright (C) 2015 Luke Shumaker
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+# Both of these have the argument order "parent,child"
+_noslash = $(patsubst %/,%,$1)
+_relto = $(call _noslash,$(patsubst $(abspath $1)/%,%,$(abspath $2)/))
+_is_subdir = $(filter $(abspath $1)/%,$(abspath $2)/)
+
+## Declare the standard targets
+all: build
+.PHONY: all
+
+## Set topobjdir, objdir, and srcdir (assumes that topsrcdir is already set)
+ifeq ($(topobjdir),)
+topobjdir := $(call _noslash,$(dir $(lastword $(filter %/config.mk config.mk,$(MAKEFILE_LIST)))))
+endif
+ objdir := $(call _noslash,$(dir $(lastword $(filter-out %.mk,$(MAKEFILE_LIST)))))
+ srcdir := $(firstword $(call _relto,., $(topsrcdir)/$(call _relto,$(topobjdir),$(objdir)) ) .)
+
+## Set module name
+module := $(firstword $(subst /,_,$(if $(call _is_subdir,.,$(objdir)),$(call _relto,.,$(objdir)),dep-$(call _relto,$(topobjdir),$(objdir)))) all)
+
+## Empty variables for use by the module
+subdirs =
+depdirs =
+
+src_files =
+obj_files =
+sys_files =
+
+clean_files =
+
+slow_files =
+conf_files =
+dist_files =