summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
commit7e704d7ac997387341e920e1757c24cac0efe5e9 (patch)
treea9f30eabaaad5496397a91053d3e03bab1ea57e4 /config.mk
parent7785a72495e3eb0ea826b41720c241f58a15b601 (diff)
Refactor the build system. Avoid recursive make.
This looks like a lot, but more things should "just work". We have `make dist` now!
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk15
1 files changed, 10 insertions, 5 deletions
diff --git a/config.mk b/config.mk
index a43581e..414f761 100644
--- a/config.mk
+++ b/config.mk
@@ -1,8 +1,13 @@
-# Configuration
-# Note: $(topdir) is set to the directory containing this file.
+# Note: In the default version of this file, commented out values
+# indicate what the GNU standards dictate, when our values
+# differ. We're not a GNU package.
-# Note: In the default version of this file, commented out values indicate what
-# the GNU standards dictate, when our values differ.
+ifeq ($(topsrcdir),)
+topsrcdir := $(patsubst %/,%,$(dir $(lastword $(MAKEFILE_LIST))))
+endif
+
+PACKAGE = libretools
+VERSION = $(LIBRETOOLS_VERSION)
DESTDIR =
@@ -21,5 +26,5 @@ sysconfdir = /etc
docdir = $(datarootdir)/doc
mandir = $(datarootdir)/man
-devtoolsdir = $(topdir)/../devtools-par
+devtoolsdir = $(call abspath,$(topsrcdir)/../devtools-par)
RONNFLAGS = --manual='libretools Manual' --organization='Parabola'