summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 14:46:36 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 18:54:01 -0500
commitdc9339b5699ee3b0d48145a1389f93e9e09d02a6 (patch)
treeed71bd691ea6e0d05d47e2bfd891c333bf5709ab /config.mk
parent4f9203808ef9607ae27eba3cf77079bbe661fd95 (diff)
Update and tidy the build system for autothing v3.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk15
1 files changed, 8 insertions, 7 deletions
diff --git a/config.mk b/config.mk
index 69a1bb9..0d564e0 100644
--- a/config.mk
+++ b/config.mk
@@ -2,16 +2,15 @@
# indicate what the GNU standards dictate, when our values
# differ. We're not a GNU package.
-ifeq ($(topsrcdir),)
+ifeq ($(origin topsrcdir),undefined)
+topsrcdir := $(patsubst %/,%,$(dir $(lastword $(MAKEFILE_LIST))))
+topoutdir := $(topsrcdir)
-topoutdir := $(patsubst %/,%,$(dir $(lastword $(MAKEFILE_LIST))))
-topsrcdir := $(topoutdir)
-
-MAKEFLAGS += --warn-undefined-variables
-include $(topsrcdir)/build-aux/no-builtin-variables.mk
+# In case .srcversion-libretools.mk hasn't been generated yet.
+LIBRETOOLS_VERSION ?= 0
PACKAGE = libretools
-VERSION = $(firstword $(LIBRETOOLS_VERSION) 0)
+VERSION = $(LIBRETOOLS_VERSION)
DESTDIR =
@@ -35,4 +34,6 @@ RONNFLAGS = --manual='libretools Manual' --organization='Parabola'
TESTENVFLAGS ?=
+.LIBPATTERNS ?=
+
endif