summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-06-09 15:55:33 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-06-09 15:55:33 -0400
commitd330445fb7f84748e70e67ca5bc44ce0a1a258f7 (patch)
tree0c1c957298635b7ba0ff69c2fe76af647304a631 /config.mk
parentf579b669d45c02b39474827f12522ff4afa6cf4a (diff)
Work with the new version of autothing.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/config.mk b/config.mk
index 414f761..5c45630 100644
--- a/config.mk
+++ b/config.mk
@@ -3,11 +3,14 @@
# differ. We're not a GNU package.
ifeq ($(topsrcdir),)
-topsrcdir := $(patsubst %/,%,$(dir $(lastword $(MAKEFILE_LIST))))
-endif
+
+topoutdir := $(patsubst %/,%,$(dir $(lastword $(MAKEFILE_LIST))))
+topsrcdir := $(topoutdir)
+
+include $(topsrcdir)/build-aux/no-builtin-variables.mk
PACKAGE = libretools
-VERSION = $(LIBRETOOLS_VERSION)
+VERSION = $(firstword $(LIBRETOOLS_VERSION) 0)
DESTDIR =
@@ -28,3 +31,5 @@ mandir = $(datarootdir)/man
devtoolsdir = $(call abspath,$(topsrcdir)/../devtools-par)
RONNFLAGS = --manual='libretools Manual' --organization='Parabola'
+
+endif