summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-09-29 12:53:47 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-09-29 18:48:52 -0400
commit3473a80a47f2cadc729f3be05fa7485ae5b12e22 (patch)
tree11389bfb491fb51a09c254c7c8f9142b18a68b42 /doc
parent76ddd033cdd42887be4a0723e613df0f9e9c4b6a (diff)
Strip trailing whitespace everywhere.
find * -type f -not -name '*.patch' -exec sed -i -r 's/\s+$//' {} +
Diffstat (limited to 'doc')
-rw-r--r--doc/treepkg.md10
-rw-r--r--doc/workflows.md4
2 files changed, 7 insertions, 7 deletions
diff --git a/doc/treepkg.md b/doc/treepkg.md
index 7f7ece1..1e30e33 100644
--- a/doc/treepkg.md
+++ b/doc/treepkg.md
@@ -67,18 +67,18 @@ Your HOOKLOCALRELEASE script should look like this:
source PKGBUILD
unset build package check
-
+
fullver=$(full_version ${epoch:-0} ${pkgver} ${pkgrel})
pkgs=()
-
+
# Generate canonical package paths
msg "Adding packages to [stage3]..."
for name in ${pkgname[@]}; do
msg2 "${name} ${fullver}"
pkgs+=("${PKGDEST}/${name}-${fullver}-*.pkg.tar.*")
done
-
- # Add the packages to a local
+
+ # Add the packages to a local
repo-add ${PKGDEST}/stage3.db.tar.gz ${pkgs[@]}
# Stage the packages for later releasing
@@ -109,7 +109,7 @@ current one. Thus this will become the build path:
> a really long build tree with some circular dependencies you may find
> packages buried several times and queued to build before their actuals deps.
-## Tips
+## Tips
`treepkg` accepts two arguments: 1) the temporary work dir and 2) the next
depth level it should use (if current equals 0, it'll pass 1). You don't need
diff --git a/doc/workflows.md b/doc/workflows.md
index f55ae7e..fe3c12e 100644
--- a/doc/workflows.md
+++ b/doc/workflows.md
@@ -28,7 +28,7 @@ This is how the chroot is configured:
* Bind mount /var/cache/pacman/pkg to /chroot/var/cache/pacman/pkg
* Put these on system's fstab so I don't have to do it everytime
-
+
* Configure makepkg.conf to PKGDEST=CacheDir and SRCDEST to something on my home.
Workflow:
@@ -50,7 +50,7 @@ What this allows:
* Building many packages in a row without recreating a chroot for every one of
them.
-
+
* Knowing that any change you made to the chroot stays as you want (no one
touches your makepkg.conf)