summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-07-27 15:19:11 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-07-27 15:19:11 -0600
commitc2d396b20c1b0fc1ed3b070a41c9ed07c3930bde (patch)
tree7aa178a17fc79711a6c312f1dbf1657d1082c901 /doc
parent05463eaf611f4784b3693b74029c3f5a6da1d70b (diff)
revamp the Makefiles to support manpages
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 7af3750..4e496f3 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -1,2 +1,16 @@
-libre_datadir=$(docdir)/libretools
-include ../common.mk
+topdir := $(realpath ..)
+include $(topdir)/config.mk
+
+files = $(wildcard *.md)
+
+all: PHONY build
+build: PHONY
+
+install: $(addprefix $(DESTDIR)$(docdir)/libretools/,$(files))
+
+$(DESTDIR)$(docdir)/libretools/%: %
+ install -Dm644 '$<' '$@'
+
+FORCE: PHONY
+PHONY:
+.PHONY: FORCE PHONY