summaryrefslogtreecommitdiff
path: root/fullpkg-find
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2012-01-22 23:06:56 -0600
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2012-01-22 23:06:56 -0600
commit7a00f2a55b69c39ae8ebad99b3d91a509b614b1b (patch)
tree7ca94ca289c069374cac149545a86234270d8fe6 /fullpkg-find
parent825ac89cfa857e4379e9e1baf6d470cf9e583dde (diff)
parent0985429b68d8da1016bf4a84b2a2d32fb8c3027c (diff)
Merge branch 'master' of gitpar:libretools
Diffstat (limited to 'fullpkg-find')
-rw-r--r--fullpkg-find9
1 files changed, 9 insertions, 0 deletions
diff --git a/fullpkg-find b/fullpkg-find
index 25565ae..d253913 100644
--- a/fullpkg-find
+++ b/fullpkg-find
@@ -11,6 +11,14 @@ guess_repo() {
basename $(dirname $(pwd))
}
+# Finds a PKGBUILD on toru's path cache
+# Look in all caches but pick the first one
+# TODO move to a toru flag (-p?)
+where_is() {
+ grep -m1 "^${1}:" "${TORUPATH}/paths" 2>/dev/null| \
+ cut -d: -f2 2>/dev/null
+}
+
# return : full version spec, including epoch (if necessary), pkgver, pkgrel
# usage : get_fullver( ${epoch:-0}, $pkgver, $pkgrel )
get_fullver() {
@@ -71,6 +79,7 @@ find_deps() {
for _dep in ${deps[@]}; do
local found=false
+# TODO change for where_is or toru-path
local pkgdir=$(toru -p ${_dep})
if [ -n "$pkgdir" -a -d "${pkgdir}" ]; then