summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorNicolas Reynolds <fauno@kiwwwi.com.ar>2011-05-08 21:57:10 -0300
committerNicolas Reynolds <fauno@kiwwwi.com.ar>2011-05-08 21:57:10 -0300
commitd12f9a0ac7ce2ff20ce59e3603ce0783c473ffb6 (patch)
treecb877ebe89769673977ade39cb440bc1dd947adc /fullpkg
parentc0bb90f5818ae2c5d40f125f3c5982b92358c68c (diff)
Add mips64el to arch array if missing, check is_built with pkgrel
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg11
1 files changed, 8 insertions, 3 deletions
diff --git a/fullpkg b/fullpkg
index 696e97f..c292bdd 100755
--- a/fullpkg
+++ b/fullpkg
@@ -108,7 +108,7 @@ repo=${1:-$(guess_repo)}
source PKGBUILD
msg "Building ${repo:-missing repo}/${pkgbase:-${pkgname[@]}}: $pkgdesc"
-is_built "${pkgbase:-${pkgname[0]}}>=${pkgver}" && exit 0
+is_built "${pkgbase:-${pkgname[0]}}>=${pkgver}-${pkgrel}" && exit 0
#sudo pacman -Sy
@@ -124,6 +124,11 @@ check_queue || exit 1
failed=()
missing=()
+if ! grep mips64el PKGBUILD >/dev/null; then
+ msg "Adding mips64el arch"
+ sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" "PKGBUILD"
+fi
+
# Gets the dependency list from the package_* functions
#pkgdeps=($(cat PKGBUILD | \
# tr -d "\n" | \
@@ -152,11 +157,11 @@ for _dep in ${deps[@]}; do
# TODO find split packages
[[ -e "$ABSROOT/${_repo}/$_dep/PKGBUILD" ]] && {
source "$ABSROOT/${_repo}/$_dep/PKGBUILD"
- msg2 "Checking for $_dep>=$pkgver"
+ msg2 "Checking for $_dep>=$pkgver-$pkgrel"
# If this version is built, continue with the next dep
- if is_built "$_dep>=$pkgver"; then
+ if is_built "$_dep>=$pkgver-$pkgrel"; then
msg2 "No need to build this one"
break
fi