summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-05 18:06:39 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-05 18:06:39 -0500
commit407d3f31705ce09a6b2f0623205de2cd8c991400 (patch)
treeb74f9773fc3e2dfccc6c51a0d053b1cdbecd733c /fullpkg
parentf42a4c74f8d9422c3ef5101dda199ed988dffd09 (diff)
* remove_queue to use "grep -E"
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg29
1 files changed, 15 insertions, 14 deletions
diff --git a/fullpkg b/fullpkg
index a95f59d..410584a 100755
--- a/fullpkg
+++ b/fullpkg
@@ -10,7 +10,7 @@ source /usr/bin/libremessages
[ -r $XDG_CONFIG_HOME/libretools/libretools.conf ] && \
source $XDG_CONFIG_HOME/libretools/libretools.conf
-## START FUNCTIONS ##
+##### START FUNCTIONS #####
function usage {
echo "cd to a dir containing a PKGBUILD and run:"
@@ -67,7 +67,7 @@ update_queue() {
remove_queue() {
get_queue
- grep -vw "^$(basename $PWD)" $queue_file > $queue_file.2
+ grep -Evw "^$(basename $PWD)" $queue_file > $queue_file.2
mv $queue_file.2 $queue_file
put_queue && return 0 || return $?
@@ -238,20 +238,21 @@ function _pkg_build () {
# this buildcmd is on libretools.conf
$FULLBUILDCMD; r=$?
case $r in
- 0) plain "The build was succesful."
- source .INFO && [ -n $repo ] && {
- librestage $repo || {
- echo "unstaged:$(basename $PWD)" >> $build_dir/log
+###### Succesfull Build ######
+ 0)
+ plain "The build was succesful."
+ source .INFO && [ -n $repo ] && {
+ librestage $repo || {
+ echo "unstaged:$(basename $PWD)" >> $build_dir/log
+ }
}
- }
- echo "built:$(basename $PWD)" >> $build_dir/log
- cleanup "$(basename $PWD)"
- ;;
- 1) error "There were errors while trying to build the package."
- echo "failed:$(basename $PWD)" >> $build_dir/log
+ echo "built:$(basename $PWD)" >> $build_dir/log
+ cleanup "$(basename $PWD)"
;;
- 2) error "The build failed."
- echo "failed:$(basename $PWD)" >> $build_dir/log
+###### Failed Build ######
+ *)
+ error "There were errors while trying to build the package."
+ echo "failed:$(basename $PWD)" >> $build_dir/log
;;
esac