summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-05-11 22:37:58 -0500
committerJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-05-11 22:37:58 -0500
commit6dfbe0e2ab6178a243a732aab721da6d2b583745 (patch)
tree573a6ff0ebb8c49cc1352e92970b4bb056c4c4cb /fullpkg
parentbf87a77517cb5d960865faaf820decaa338c4f63 (diff)
Some message changes and cleanup
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg39
1 files changed, 8 insertions, 31 deletions
diff --git a/fullpkg b/fullpkg
index c292bdd..f74c0b5 100755
--- a/fullpkg
+++ b/fullpkg
@@ -86,7 +86,7 @@ check_queue() {
# Checks if the package is banned from building
is_banned() {
rsync -e ssh -aq $PARABOLAHOST:mips64el/ban $ban_file >/dev/null 2>&1 || {
- echo ":: Failed to get ban list"
+ plain ":: Failed to get ban list"
return 0
}
@@ -95,7 +95,6 @@ is_banned() {
return $?
}
-
# TODO keep track of spawned fullpkgs
quit() {
remove_queue
@@ -108,9 +107,8 @@ repo=${1:-$(guess_repo)}
source PKGBUILD
msg "Building ${repo:-missing repo}/${pkgbase:-${pkgname[@]}}: $pkgdesc"
-is_built "${pkgbase:-${pkgname[0]}}>=${pkgver}-${pkgrel}" && exit 0
-
-#sudo pacman -Sy
+is_built "${pkgbase:-${pkgname[0]}}>=${pkgver}-${pkgrel}" && \
+ msg2 "This package is built." && exit 0
trap "quit" TERM KILL INT
@@ -129,15 +127,6 @@ if ! grep mips64el PKGBUILD >/dev/null; then
sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" "PKGBUILD"
fi
-# Gets the dependency list from the package_* functions
-#pkgdeps=($(cat PKGBUILD | \
-# tr -d "\n" | \
-# sed -n "s/depends=(\([^)]\+\))/\n::\1\n/pg" | \
-# grep --color=never "^::" | \
-# tr -d [:\'\"] | \
-# tr " " "\n" | \
-# sort -u))
-
# Clean version checking
deps=$(echo "${depends[@]} ${makedepends[@]} ${pkgdeps[@]}" | \
sed "s/[=<>]\+[^ ]\+//g" | \
@@ -145,10 +134,6 @@ deps=$(echo "${depends[@]} ${makedepends[@]} ${pkgdeps[@]}" | \
sort -u)
msg "Checking dependencies"
-plain "${deps[@]}"
-
-#msg "Syncing database"
-#sudo pacman -Sy
for _dep in ${deps[@]}; do
is_banned $_dep && continue
@@ -162,7 +147,7 @@ for _dep in ${deps[@]}; do
# If this version is built, continue with the next dep
if is_built "$_dep>=$pkgver-$pkgrel"; then
- msg2 "No need to build this one"
+ plain "No need to build this one"
break
fi
@@ -194,18 +179,10 @@ for _dep in ${deps[@]}; do
done
# TODO probably not elegant enough
-# [[ ${#failed[@]} -gt 0 ]] || [[ ${#missing[@]} -gt 0 ]] && {
- [[ ${#failed[@]} -gt 0 ]] && {
- error "This packages failed to build: ${failed[@]}"
- exit 1
- }
-
-# [[ ${#missing[@]} -gt 0 ]] && {
-# echo ":: This packages are missing: ${missing[@]}"
-# }
-
-# exit 1
-#}
+[[ ${#failed[@]} -gt 0 ]] && {
+ error "This packages failed to build: ${failed[@]}"
+ exit 1
+}
# Let everybody know we're building this
update_queue || {