summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-24 17:17:17 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-24 17:17:17 -0500
commitad11f4aee0e7af9dcba780d464edef34cc937d4a (patch)
tree4d167c0b2bafd016949da3cbf50a2f36f6a840f3 /fullpkg
parentf245468672503e4066b46307aff3c39c23983904 (diff)
parent73f49edd89a1bb4ed023b81bfcf113d4a6956887 (diff)
Merge http://projects.parabolagnulinux.org/libretools
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg22
1 files changed, 13 insertions, 9 deletions
diff --git a/fullpkg b/fullpkg
index f6640dc..264a910 100755
--- a/fullpkg
+++ b/fullpkg
@@ -5,7 +5,6 @@
source /etc/makepkg.conf
source /etc/abs.conf
source /etc/libretools.conf
-source /usr/bin/libremessages
# Avoid /libretools dir doesn't exist errors
if [ -z $XDG_CONFIG_HOME ]; then
@@ -187,13 +186,17 @@ function find_deps {
# Increase build level
declare -i next_level=$level+1
+
+# Pass the offline flag to children
+ [[ "$OFFLINE" -eq true ]] && extra+=" -o"
for _dep in ${deps[@]}; do
for _repo in ${REPOS[@]}; do
# try to find $_dep on each repo from dirname
if [ -e "${ABSROOT}/${_repo}/${_dep}/PKGBUILD" ]; then
pushd "${ABSROOT}/${_repo}/${_dep}" > /dev/null
- $0 -c -d ${build_dir} -l ${next_level}
+
+ $0 -c -d ${build_dir} -l ${next_level} ${extra}
# Circular deps must fail
[ $? -eq 20 ] && return 20
@@ -288,7 +291,7 @@ function _pkg_build () {
}
msg "Updating pacman db and packages"
- sudo pacman -Syu --noconfirm || true
+ sudo pacman -Sy || true
}
echo "built:$(basename $PWD)" >> $build_dir/log
@@ -301,10 +304,10 @@ function _pkg_build () {
esac
# Package was built or failed: take it out of $buildorder
- remove_buildorder "${build_packages[0]}" $buildorder
+ remove_buildorder "${build_packages[0]}" $buildorder || true
# Take package out from queue
- remove_queue
+ remove_queue || true
# Set build_packages before next cycle run
build_packages=($(sort -gr $buildorder | cut -d: -f2))
@@ -400,11 +403,12 @@ if [ ${build_only} == 'n' ]; then
usage && exit 1
}
+fi
+
# Add mips64el if missing from arch=() and it isn't an 'any' package
- if ! grep mips64el PKGBUILD >/dev/null; then
- plain "Adding mips64el arch"
- sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" "PKGBUILD"
- fi
+if ! grep mips64el PKGBUILD >/dev/null; then
+ warning "Adding mips64el arch"
+ sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" "PKGBUILD"
fi
# If the queue file isn't writable go into offline mode