summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-02 13:06:51 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-02 13:06:51 -0500
commitaf74e1a5884a23e29289c661c74fadbf72d794e7 (patch)
tree04a518ba02ff271dbc21e7cfe9343deeb8a5da5b /fullpkg
parentd469eb6ba3891e93373dd899a7b0660c1101e12d (diff)
* find_deps guess is made only on var declaration
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg3
1 files changed, 2 insertions, 1 deletions
diff --git a/fullpkg b/fullpkg
index 213bf5e..14c4e9f 100755
--- a/fullpkg
+++ b/fullpkg
@@ -162,8 +162,9 @@ function find_deps {
# if search pkgname in repo doesn't work
# this should find pkgsplits
elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 | \
- "xargs" -0 -e grep -HEw "pkgname|pkgbase|provides" | grep $_dep 2>&1));
+ "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep $_dep 2>&1));
then
+ plain "guess for $_dep -> $_dir"
pushd $(dirname $(echo $_dir | cut -d: -f1)) > /dev/null
$0 -c -d ${build_dir} -l ${next_level}
# Circular deps must fail