summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-25 11:46:03 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-25 11:46:03 -0500
commitd94747c063e65cb5bbe99246157d76079cc4c252 (patch)
tree77769922f469f1c7ca80e138041a25b31b35dd0f /fullpkg
parentbfc22659aff2cc2a2832b34b7f044146e5b86184 (diff)
*fullpkg don't add mipsel on build_only
*mipsrelease adds pkgs from pkgdest
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg10
1 files changed, 5 insertions, 5 deletions
diff --git a/fullpkg b/fullpkg
index 6e9ea19..ce31dd4 100755
--- a/fullpkg
+++ b/fullpkg
@@ -398,12 +398,12 @@ if [ ${build_only} == 'n' ]; then
usage && exit 1
}
-fi
-
# Add mips64el if missing from arch=() and it isn't an 'any' package
-if ! grep mips64el PKGBUILD >/dev/null; then
- warning "Adding mips64el arch"
- sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" "PKGBUILD"
+ if ! grep mips64el PKGBUILD >/dev/null; then
+ warning "Adding mips64el arch"
+ sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" "PKGBUILD"
+ fi
+
fi
# If the queue file isn't writable go into offline mode