summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-02 13:31:17 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-02 14:12:49 -0500
commitf0f010772d651e09f957f9b47057e81e7737ad45 (patch)
tree912fb2eb8145c33c92403ab7032ad20d03294f73 /fullpkg
parentaf74e1a5884a23e29289c661c74fadbf72d794e7 (diff)
fullpkg shows guessed dir
libretools.conf has reordered repos before community
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg7
1 files changed, 4 insertions, 3 deletions
diff --git a/fullpkg b/fullpkg
index 14c4e9f..a95f59d 100755
--- a/fullpkg
+++ b/fullpkg
@@ -161,11 +161,12 @@ function find_deps {
# if search pkgname in repo doesn't work
# this should find pkgsplits
- elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 | \
- "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep $_dep 2>&1));
+ elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 2>/dev/null | \
+ "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep -w "$_dep" 2>&1));
then
+ _dir=$(dirname $(echo $_dir | cut -d: -f1))
plain "guess for $_dep -> $_dir"
- pushd $(dirname $(echo $_dir | cut -d: -f1)) > /dev/null
+ pushd $_dir > /dev/null
$0 -c -d ${build_dir} -l ${next_level}
# Circular deps must fail
[ $? -eq 20 ] && return 20