summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorNicolas Reynolds <fauno@kiwwwi.com.ar>2011-05-22 11:17:18 -0300
committerNicolas Reynolds <fauno@kiwwwi.com.ar>2011-05-22 11:17:18 -0300
commit8fb0261cb367ffb05190e34ae6b0fc0dba4f8d38 (patch)
tree2736f191f5e7cedfc75e78009ef6766c89657e0d /fullpkg
parent4f1392d774c081a03d9abab0c731704880d54d4c (diff)
Fixed some spacing missing and removed librerelease. It can be done at the end
of the batch building and testing process and it's not really needed since mipsrelease does it on a local repo.
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg20
1 files changed, 10 insertions, 10 deletions
diff --git a/fullpkg b/fullpkg
index d66067e..974dc85 100755
--- a/fullpkg
+++ b/fullpkg
@@ -209,16 +209,16 @@ for _dep in ${deps[@]}; do
source "$ABSROOT/${_repo}/$_dep/PKGBUILD"
msg2 "Checking for $_dep>=$pkgver-$pkgrel"
- if ! in_array $_dep ${force_array[@]}; then
- if is_built "$_dep>=$pkgver-$pkgrel"; then
- plain "this package is built"
- break
- fi
- else
- _fullpkgargs+="-f "
- _fullpkgargs="$(echo $_fullpkgargs | sed s/"-R $_dep "//)"
- force_array=( $(echo ${forcearray[@]} | tr " " "\n" | grep -vw "^$_dep") )
- fi
+ if ! in_array $_dep ${force_array[@]}; then
+ if is_built "$_dep>=$pkgver-$pkgrel"; then
+ plain "this package is built"
+ break
+ fi
+ else
+ _fullpkgargs+="-f "
+ _fullpkgargs="$(echo $_fullpkgargs | sed s/"-R $_dep "//)"
+ force_array=( $(echo ${forcearray[@]} | tr " " "\n" | grep -vw "^$_dep") )
+ fi
cp -r "$ABSROOT/$_repo/$_dep" $tmp_dir/ || {
error "Can't copy $_dep to the work dir."