summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorNicolas Reynolds <fauno@kiwwwi.com.ar>2011-06-20 23:09:02 -0300
committerNicolas Reynolds <fauno@kiwwwi.com.ar>2011-06-20 23:09:02 -0300
commit59b03ff6bb15a5163604ad8ba344a8fd2f664826 (patch)
treeb780564f9857e372ba81091973d96b2ded99f14e /fullpkg
parent7d2a691276f60e10c59204631f06fa9c5d6a1c25 (diff)
parent702cc20bd94cdb2939e0c163e8e9671c920c5b19 (diff)
Merge branch 'master' of ssh://vparabola/srv/git/projects/libretools
Conflicts: fullpkg
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg33
1 files changed, 17 insertions, 16 deletions
diff --git a/fullpkg b/fullpkg
index 33dd4f2..b7f09ba 100755
--- a/fullpkg
+++ b/fullpkg
@@ -205,17 +205,17 @@ function find_deps {
# if search pkgname in repo doesn't work
# this should find pkgsplits
-# elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 2>/dev/null | \
-# "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep -w "$_dep" 2>&1));
-# then
-# _dir=$(dirname $(echo $_dir | cut -d: -f1))
-# plain "guess for $_dep -> $_dir"
-# pushd $_dir > /dev/null
-# $0 -c -d ${build_dir} -l ${next_level}
-## Circular deps must fail
-# [ $? -eq 20 ] && return 20
-# popd > /dev/null
-# break 1 # found, go to next dep
+ elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 2>/dev/null | \
+ "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep -w "$_dep" 2>&1));
+ then
+ _dir=$(dirname $(echo $_dir | cut -d: -f1))
+ plain "guess for $_dep -> $_dir"
+ pushd $_dir > /dev/null
+ $0 -c -d ${build_dir} -l ${next_level}
+# Circular deps must fail
+ [ $? -eq 20 ] && return 20
+ popd > /dev/null
+ break 1 # found, go to next dep
else
echo "dep_not_found:$_dep:$_repo" >> $build_dir/log
@@ -281,8 +281,9 @@ function _pkg_build () {
source .INFO && [ -n $repo ] && {
# Calls a local release script if it's used
- [ -z "$HOOKLOCALRELEASE" ] || \
- $HOOKLOCALRELEASE $repo *.pkg.tar.?z
+ [ -z $HOOKLOCALRELEASE ] || \
+ find -name "*.pkg.tar.?z" -print0 | \
+ xargs -0 $HOOKLOCALRELEASE $repo
# Stage for releasing
librestage $repo || {
@@ -290,7 +291,7 @@ function _pkg_build () {
}
msg "Updating pacman db and packages"
- sudo pacman -Sy
+ sudo pacman -Sy || true
}
echo "built:$(basename $PWD)" >> $build_dir/log
@@ -374,7 +375,7 @@ while getopts 'ha:b:cCd:l:nm:r:o' arg; do
usage
exit 1
}
- [ -e ${build_dir}/BUILDORDER ] && {
+ [ ! -r ${build_dir}/BUILDORDER ] && {
error "${build_dir}/BUILDORDER doesn't exist."
exit 1
};;
@@ -458,7 +459,7 @@ find_deps || {
else
rsync -e ssh -aq $PARABOLAHOST:mips64el/ban >/dev/null 2>&1 || {
- warning "Failed to get ban list" && [ -r $ban_file ] && {
+ warning "Failed to get ban list" && [ -r ${ban_file} ] && {
# Use local copy of ban file if it is avaliable and continue.
search=$(cat ${ban_file} | tr "\n" "|")