summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-15 18:06:55 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-15 18:06:55 -0500
commit85c6658b23798eca85a4614cfb79719e79aae334 (patch)
tree6738f024817a99c54d12249017aac4011d8908d3 /fullpkg
parentd48d50d162315e5ce915effbd27f3600d836e56e (diff)
parentfc39fd1e991a4fc6a5aceafc619ca552ad72b582 (diff)
Merge branch 'master' of vparabola:~/projects/libretools
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg28
1 files changed, 14 insertions, 14 deletions
diff --git a/fullpkg b/fullpkg
index a03ff1b..1349e9a 100755
--- a/fullpkg
+++ b/fullpkg
@@ -175,8 +175,8 @@ function find_deps {
echo "repo=$repo" > "${build_dir}/${pkgbase}/.INFO"
fi
-# Inform the current package
- msg2 "${pkgbase}-${fullver}"
+# Inform the current package plus a space for every level for indent
+ msg2 "%${level}s${pkgbase}-${fullver}"
## Check next levels
# Clean version checking
@@ -202,17 +202,17 @@ function find_deps {
# if search pkgname in repo doesn't work
# this should find pkgsplits
- elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 2>/dev/null | \
- "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep -w "$_dep" 2>&1));
- then
- _dir=$(dirname $(echo $_dir | cut -d: -f1))
- plain "guess for $_dep -> $_dir"
- pushd $_dir > /dev/null
- $0 -c -d ${build_dir} -l ${next_level}
-# Circular deps must fail
- [ $? -eq 20 ] && return 20
- popd > /dev/null
- break 1 # found, go to next dep
+# elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 2>/dev/null | \
+# "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep -w "$_dep" 2>&1));
+# then
+# _dir=$(dirname $(echo $_dir | cut -d: -f1))
+# plain "guess for $_dep -> $_dir"
+# pushd $_dir > /dev/null
+# $0 -c -d ${build_dir} -l ${next_level}
+## Circular deps must fail
+# [ $? -eq 20 ] && return 20
+# popd > /dev/null
+# break 1 # found, go to next dep
else
echo "dep_not_found:$_dep:$_repo" >> $build_dir/log
@@ -394,7 +394,7 @@ if [ ${build_only} == 'n' ]; then
# Check if we are actually on a build directory
# Do this early
- [ -r PKGBUILD ] && {
+ [ ! -r PKGBUILD ] && {
error "This isn't a build directory"
usage && exit 1
}