summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-07 00:17:08 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-07 00:17:08 -0500
commite9bc885c355babf7851de31db8e1920dde752993 (patch)
treefd39b7d6401ead53942f66bfc4219a06f386a23f /fullpkg
parentc74d072dc83c5e3b3d9462678884cd0411a7d1d0 (diff)
organize the files
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg34
1 files changed, 0 insertions, 34 deletions
diff --git a/fullpkg b/fullpkg
deleted file mode 100755
index 9a03b82..0000000
--- a/fullpkg
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/bash
-# set -x # uncomment for debug
-# Builds packages from ABS recursively. It tries to find dependencies that
-# aren't built or need update and then makepkg them in order.
-
-usage() {
-
- echo "cd to a dir containing a PKGBUILD and run:"
- echo "$0 [build_dir]"
- echo ""
- echo "This script will check dependencies, build them if possible "
- echo "and stage the packages on it's repo."
- echo ""
- echo "OPTIONS:"
- echo " -h : this message."
- echo ""
- echo "Wrapper for \`fullpkg-find' and \`fullpkg-build'"
- echo ""
- exit 1
-
-}
-
-while getopts 'haA:l:nm:' arg; do
- case "$arg" in
- h) usage ;;
- esac
-done
-
-shift $(( OPTIND - 1 ))
-
-build_dir="${1:-$(mktemp -d /tmp/fullpkg.XXXXXX)}"
-fullpkg-find "$build_dir" && fullpkg-build -N "$build_dir"
-
-exit 0