summaryrefslogtreecommitdiff
path: root/libremakepkg
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-06-09 16:39:38 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-06-09 16:39:38 -0300
commitf21fd2185aaef0b2e9054c5eb0d4369597bcc0ff (patch)
tree04186d02d49af629a61c57dc916be885a335c693 /libremakepkg
parent1bbc75a678a69a27e18f09a9ab38d27545f013a2 (diff)
parent6d20859e305d5998358ee61d93741600fafd0b4e (diff)
Merge branch 'master' of ssh://vparabola/srv/git/projects/libretools
Conflicts: libremakepkg
Diffstat (limited to 'libremakepkg')
-rwxr-xr-xlibremakepkg4
1 files changed, 3 insertions, 1 deletions
diff --git a/libremakepkg b/libremakepkg
index 9a76f5f..3cbc844 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -67,6 +67,8 @@ fi
msg "Checking PKGBUILD for non-free issues"
pkgbuild-check-nonfree ||{
+# pkgbuild-check-nonfree uses 15 for nonfree and
+# other errors if something failed.
if [[ $? -eq 15 ]]; then
error "PKGBUILD contains non-free issues"
exit 15
@@ -75,7 +77,7 @@ pkgbuild-check-nonfree ||{
if [ $update_first = y ]; then
msg "Updating the main chroot"
- # -c option in mkarchroot indicates cache
+# -c option in mkarchroot indicates cache
mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOT}"
fi