summaryrefslogtreecommitdiff
path: root/libremakepkg
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-10-09 16:01:45 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-10-09 16:01:45 -0300
commit430d265dacd0dcbd6724342f5c79f52a9865f6a8 (patch)
tree7edc042d5a4b15cc804ced37055af4ac53e1efce /libremakepkg
parent0663c0c58a8d04a35f5ba9ab6de068a3f6c09b40 (diff)
Removed evil -c flag from makechrootpkg
Diffstat (limited to 'libremakepkg')
-rwxr-xr-xlibremakepkg40
1 files changed, 14 insertions, 26 deletions
diff --git a/libremakepkg b/libremakepkg
index ef72526..bac9e30 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -136,9 +136,7 @@ if [ ${UID} -ne 0 ]; then
fi
if [ ! -r PKGBUILD ]; then # Check if we are actually on a build directory. Do this early.
-
- error "This isn't a build directory"; usage
-
+ error "This isn't a build directory"; usage
fi
msg "Checking PKGBUILD for non-free issues"
@@ -156,33 +154,23 @@ fi
buildenv
msg "Creating the package"
-if [ -d "${CHROOTDIR}/${CHROOTNAME}" ]; then # use chroot
-
- if [ "${CLEAN_FIRST}" = 'y' ]; then
- msg "Cleaning"
- clean_chroot
- fi
-
- if [ "${UPDATE_FIRST}" = 'y' ]; then
- msg "Updating the chroot in use..."
- mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOTNAME}" # -c option is for cache
- fi
-
- makechrootpkg -r "${CHROOTDIR}" -l "${CHROOTNAME}" -- "${MAKEPKG_ARGS}"
- ev=$? # exit value
-
-else # build new chroot before using
-
- if [ "${UPDATE_FIRST}" = 'y' ]; then # update CHROOT
- msg "Updating the chroot in use..."
- mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOT}" # -c option is for cache
- fi
+if [ ! -d "${CHROOTDIR}/${CHROOTNAME}" ]; then # use chroot
+ mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOT}" # -c option is for cache
+fi
- makechrootpkg -c -r "${CHROOTDIR}" -l "${CHROOTNAME}" -- "${MAKEPKG_ARGS}"
- ev=$? # exit value
+if [ "${CLEAN_FIRST}" = 'y' ]; then
+ msg "Cleaning"
+ clean_chroot
+fi
+if [ "${UPDATE_FIRST}" = 'y' ]; then
+ msg "Updating the chroot in use..."
+ mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOTNAME}" # -c option is for cache
fi
+makechrootpkg -r "${CHROOTDIR}" -l "${CHROOTNAME}" -- "${MAKEPKG_ARGS}"
+ev=$? # exit value
+
copy_log
exit $ev