summaryrefslogtreecommitdiff
path: root/libremakepkg
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-12-24 21:11:03 -0600
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-12-24 21:11:03 -0600
commit55b66d324fb5b08651606207bec73f4d51525c7e (patch)
treef5392adee284b3512a114aa655a72e5dd26cfecc /libremakepkg
parentafeb8ee939f23256192239622f57265cf4c6cb4c (diff)
libremakepkg: uses chroot for cleaning
librechroot: clean chroot option added (uses pacman) cleansystem: updated list from a clean chroot
Diffstat (limited to 'libremakepkg')
-rwxr-xr-xlibremakepkg174
1 files changed, 56 insertions, 118 deletions
diff --git a/libremakepkg b/libremakepkg
index 2f90cce..7885f1e 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -19,97 +19,22 @@
# You should have received a copy of the GNU General Public License
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-source /etc/libretools.conf
-source /etc/makepkg.conf
-
-# Local vars may differ from chroot's
-LOCALPKGDEST=${PKGDEST}
-LOCALSRCDEST=${SRCDEST}
-LOCALSRCPKGDEST=${SRCPKGDEST}
-
-source ${CHROOTDIR}/${CHROOT}/etc/makepkg.conf
-
-function usage { # Display message and exit
-
- echo 'cd to a dir containing a PKGBUILD and run:'
- echo '$0 [options] [makepkg args]'
- echo 'This script will build your package on a chroot.'
- echo
- echo 'OPTIONS:'
- echo
- echo ' -h show this message.'
- echo ' -c cleans the chroot before building.'
- echo ' -u updates the chroot before building.'
- echo ' -n use this dir instead of "${CHROOT}".'
- echo ' -M <--arg> passes long args to makepkg, use it as many times as needed.'
- echo
- exit 1
-}
-
-function buildenv { # Mounts *DEST from makepkg.conf
-
- msg "Building env"
-# for mp in SRCDEST PKGDEST SRCPKGDEST; do
-# The host system directory
-# lmp=LOCAL${mp}
-# msg2 "Binding ${!lmp} to ${CHROOTDIR}/${CHROOT}${!mp}"
-
-# mkdir -p "${CHROOTDIR}/${CHROOT}${!mp}"
-# mount -o bind ${!lmp} "${CHROOTDIR}/${CHROOT}${!mp}" || exit 1
-# done
-
- msg2 "Bind ${CACHEDIR} => ${CHROOTDIR}/${CHROOT}/var/cache/pacman/pkg/"
- mount -o bind ${CACHEDIR} ${CHROOTDIR}/${CHROOT}/var/cache/pacman/pkg/
-
-}
-
-function clean_chroot { # Clean packages with pacman
-
- plain "making list of packages in ${CHROOTDIR}/${CHROOTNAME}/root/"
- echo "sudo
-" > "${CHROOTDIR}/${CHROOTNAME}/root/cleansystem"
- pacman -Sgq base base-devel >> "${CHROOTDIR}/${CHROOTNAME}/root/cleansystem"
- (cat <<EOF
-#!/bin/bash
-export LANG=C
-
- pkgs=(\$(comm -23 <(pacman -Qq | sort) <(sort /root/cleansystem)))
-
- if [ \${#pkgs[@]} -gt 0 ]; then
- pacman --noconfirm -Rcs \${pkgs[@]}
- pacman --noconfirm -S --needed base-devel gettext
- else
- echo "clean"
- fi
-EOF
- ) > "${CHROOTDIR}/${CHROOTNAME}/clean"
- chmod +x "${CHROOTDIR}/${CHROOTNAME}/clean"
- mkarchroot -r "/clean" "${CHROOTDIR}/${CHROOTNAME}"
-
-}
+# set -x # uncomment for debug
function copy_log { # copy logs if they exist
- if [ "${USE_LOG}" == 'y' ]; then
- find ${CHROOTDIR}/${CHROOTNAME}/build/ -name "*\.log" -exec cp {} ./ \;
- fi
+ find "${CHROOTDIR}/${CHROOTNAME}/build/" -name "*\.log" -exec cp {} ./ \;
}
-function trap_exit { # End inmediately but print a useful message
-
-# args are treated as part of the message
- for mp in ${SRCDEST} ${PKGDEST} ${SRCPKGDEST}; do
- umount "${CHROOTDIR}/${CHROOT}${mp}"
- done
+function trap_exit { # End inmediately but print a useful message
copy_log
-
error "$@"
-
exit 1
+
}
# Trap signals from makepkg
@@ -118,69 +43,82 @@ trap 'trap_exit "(libremakepkg): TERM signal caught. Exiting..."' TERM HUP QUIT
trap 'trap_exit "(libremakepkg): Aborted by user! Exiting..."' INT
trap 'trap_exit "(libremakepkg): An unknown error has occurred. Exiting..."' ERR
-CLEAN_FIRST="n"
-CLEAN_CACHE=""
-UPDATE_FIRST="n"
-USE_LOG='n'
-CHROOTNAME=${CHROOT}
+source /etc/libretools.conf
+
+CLEANFIRST="false"
+UPDATEFIRST="false"
+CHECKNONFREE="true"
+LIBRECHROOT_ARGS=""
MAKEPKG_ARGS=""
-libremakepkgargs='hcuUn:I:M:' # libremakepkg own args
-libremakepkgargs+='ACdefiLmop:rRs' # makepkg args
+function usage {
+
+ echo 'cd to a dir containing a PKGBUILD and run:'
+ echo '$0 [options] [-- makechrootpkg args] [-- makepkg args]'
+ echo 'This script will build your package on a chroot.'
+ echo ''
+ echo 'OPTIONS:'
+ echo ''
+ echo ' -h : show this message.'
+ echo ' -c : clean the chroot before building.'
+ echo ' -u : update the chroot before building.'
+ echo ' -d <chrootdir> : use this dir instead of "$CHROOTDIR"'
+ echo ' -n <chrootname> : use this dir instead of "$CHROOT".'
+ echo ' -N : do not check freedom issues' # As fullpkg-check will do that before
+ echo ''
+ exit 1
+
+}
-while getopts ${libremakepkgargs} arg ; do
+while getopts 'hcud:n:N' arg ; do
case "${arg}" in
h) usage ;;
- c) CLEAN_FIRST="y" ;;
- u) UPDATE_FIRST="y" ;;
- n) CHROOTNAME="$OPTARG" ;;
- M) MAKEPKG_ARGS+=" $OPTARG" ;;
- L) MAKEPKG_ARGS+=" -$arg $OPTARG"
- USE_LOG='y';;
- *) MAKEPKG_ARGS+=" -$arg $OPTARG" ;;
+ c) CLEANFIRST="true" ;;
+ u) UPDATEFIRST="true" ;;
+ d) CHROOTDIR="$OPTARG"
+ LIBRECHROOT_ARGS='-d "$OPTARG"' ;;
+ n) CHROOT="$OPTARG" ;;
+ N) CHECKNONFREE="false" ;;
esac
done
-if [ ${UID} -ne 0 ]; then
+# Pass all arguments after -- right to makechrootpkg
+MAKEPKG_ARGS="$makepkg_args ${*:$OPTIND}"
+
+if (( EUID )); then
error "This script must be run as root"
exit 1
fi
-if [ ! -r PKGBUILD ]; then # Check if we are actually on a build directory. Do this early.
+if [ ! -e PKGBUILD ]; then # Check if we are actually on a build directory. Do this early.
error "This isn't a build directory"; usage
fi
msg "Checking PKGBUILD for non-free issues"
-if ! pkgbuild-check-nonfree; then
-
- if [[ $? -eq 15 ]]; then # other errors mean fail, not nonfree
- error "PKGBUILD contains non-free issues"
- exit 15
- else
- true
+if (( CHECKNONFREE )); then
+ if ! pkgbuild-check-nonfree; then
+
+ if [[ $? -eq 15 ]]; then # other errors mean fail, not nonfree
+ error "PKGBUILD contains non-free issues"
+ exit 15
+ else
+ warning "PKGBUILD couldn't be check aganist non-free issues"
+ fi
fi
-
fi
-buildenv
-
-msg "Creating the package"
-if [ ! -d "${CHROOTDIR}/${CHROOTNAME}" ]; then # use chroot
- mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOT}" # -c option is for cache
+if (( CLEANFIRST )); then
+ librechroot -c "$LIBRECHROOT_ARGS" "$CHROOT"
fi
-if [ "${CLEAN_FIRST}" = 'y' ]; then
- msg "Cleaning"
- clean_chroot
+if (( UPDATEFIRST )); then
+ librechroot -u "$LIBRECHROOT_ARGS" "$CHROOT"
fi
-if [ "${UPDATE_FIRST}" = 'y' ]; then
- msg "Updating the chroot in use..."
- mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOTNAME}" # -c option is for cache
-fi
+unset CLEANFIRST UPDATEFIRST LIBRECHROOT_ARGS
-makechrootpkg -r "${CHROOTDIR}" -l "${CHROOTNAME}" -- "${MAKEPKG_ARGS}"
-ev=$? # exit value
+makechrootpkg -r "$CHROOTDIR" -l "$CHROOT" "$MAKEPKG_ARGS"
+ev="$?" # exit value
copy_log