summaryrefslogtreecommitdiff
path: root/librerelease
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2010-09-23 10:54:23 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2010-09-23 10:54:23 -0300
commit4ac274c48e2cd0fdedf23044383c39a8ee15a141 (patch)
tree13c339fbff3895aba052617719aaae6b4d376f30 /librerelease
librerelease script
Uploads the package to the free repo and moves old versions to old/ dir Usage: librerelease <[core,extra,community]>
Diffstat (limited to 'librerelease')
-rwxr-xr-xlibrerelease42
1 files changed, 42 insertions, 0 deletions
diff --git a/librerelease b/librerelease
new file mode 100755
index 0000000..5b5c575
--- /dev/null
+++ b/librerelease
@@ -0,0 +1,42 @@
+#!/bin/bash
+
+host=parabola
+dir=parabolagnulinux.org/repo/free
+batchfile=/tmp/librerelease_batchfile.$$
+
+repo=${1}
+
+if [ ${#repo} -eq 0 ]; then exit 1; fi
+
+function to_sftp() {
+ echo "$@" >> $batchfile
+}
+
+if [ ! -e ./PKGBUILD ]; then exit 1; fi
+
+source PKGBUILD
+source /etc/makepkg.conf
+
+if [ -e ~/.makepkg.conf ]; then source ~/.makepkg.conf; fi
+
+
+# Init the batchfile
+to_sftp "progress"
+
+# Move out the old packages
+
+for _arch in ${arch[@]}; do
+ for pkg in ${pkgname[@]}; do
+ pkgfile="$PKGDEST/$pkg-$pkgver-$pkgrel-$_arch$PKGEXT"
+ if [ -e "$pkgfile" ]; then
+# This has to be moved to repo-maintainer
+ ssh parabola mv $dir/$repo/os/$_arch/$pkg-*-*-$_arch$PKGEXT $dir/old/
+
+ to_sftp "put $pkgfile $dir/$repo/os/$_arch/"
+ fi
+ done
+done
+
+sftp -b ${batchfile} $host
+
+exit 0