summaryrefslogtreecommitdiff
path: root/librerelease
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2010-10-19 14:33:33 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2010-10-19 14:33:33 -0500
commit1d62989f49eb7e8cc387758e9ff623fe947cc418 (patch)
treed85a9d594fc1f7840b407de61dcc34d3d5d3812e /librerelease
parent0f19f735d943692d8ee4ec15081a558198acacb0 (diff)
Use /home/joshpar/.config and added usage function
Diffstat (limited to 'librerelease')
-rwxr-xr-xlibrerelease15
1 files changed, 13 insertions, 2 deletions
diff --git a/librerelease b/librerelease
index f1b9cd4..c7b21e6 100755
--- a/librerelease
+++ b/librerelease
@@ -21,15 +21,26 @@
# You should have received a copy of the GNU General Public License
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-source /etc/libretools.conf
+if [-e $XDG_CONFIG_HOME/.libretools.conf]; then
+ source $XDG_CONFIG_HOME/.libretools.conf
+else
+ source /etc/libretools.conf
+fi
batchfile=/tmp/librerelease_batchfile.$$
# End Config
+usage() {
+ echo "Usage: $0 <repo> "
+ echo ""
+ echo "Libre release will upload the package and source built by the PKGBUILD on the"
+ echo "current directory to the specified repo."
+}
+
repo=${1}
if [ ${#repo} -eq 0 ]; then
- echo "Usage: $0 <repo>"
+ usage
exit 1;
fi