summaryrefslogtreecommitdiff
path: root/librerelease
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2011-02-08 22:35:05 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2011-02-08 22:35:05 -0300
commitb279674cdc555740efcc4bebee642467226add6b (patch)
tree08ca5910a1688f4c24ca7b9a4b57914410c39871 /librerelease
parentf874a3af8b0f3d32b26dcfa4a8b57b4220e3851f (diff)
Removed extra space from license messages
Diffstat (limited to 'librerelease')
-rwxr-xr-xlibrerelease102
1 files changed, 21 insertions, 81 deletions
diff --git a/librerelease b/librerelease
index b47237b..ad083a3 100755
--- a/librerelease
+++ b/librerelease
@@ -2,84 +2,29 @@
# Librerelease
# Uploads packages into [staging]
-# Copyright 2010 Nicolás Reynolds
-
-# ---------- GNU General Public License 3 ----------
-
-# This file is part of Parabola.
-
-# Parabola is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-
-# Parabola is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-
-# You should have received a copy of the GNU General Public License
-# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
source /etc/libretools.conf
custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
[[ -e $custom_config ]] && source $custom_config
-# End Config
-
-usage() {
- echo "Usage: $0 <repo> [<repo2> ... ]"
- echo ""
- echo "LibreRelease will upload the package built by the PKGBUILD on the"
- echo "current directory to the specified repo."
-}
-
-repos=$@
-
-if [ ${#repos} -eq 0 ]; then
- usage
- exit 1;
-fi
-
-[[ ! -e ./PKGBUILD ]] && {
- echo "PKGBUILD not found"
- exit 1
-}
-
-# Source the needed files
-source PKGBUILD
-source /etc/makepkg.conf
-[[ -e ~/.makepkg.conf ]] && source ~/.makepkg.conf
-
-# Default package location
-PKGDEST=${PKGDEST:-.}
-SRCPKGDEST=${SRCPKGDEST:-.}
-
-# Copies the packages to the specified repos inside staging
-for _arch in ${arch[@]}; do
- for pkg in ${pkgname[@]}; do
-
- pkgfile="$PKGDEST/$pkg-$pkgver-$pkgrel-$_arch$PKGEXT"
-
- if [ -e "${pkgfile}" ]; then
-
- for _repo in ${repos[@]}; do
-
- cp "${pkgfile}" "${WORKDIR}/staging/${_repo}/" || {
- echo "Can't put ${pkgfile} on [staging]"
- exit 1
- }
-
- done
-
- fi
- done
-done
-
-# Use pkgbase for finding the sources tar
-[[ -z ${pkgbase} ]] && pkgbase=${pkgname}
-
echo ":: Uploading packages..."
rsync --recursive \
--copy-links \
@@ -89,14 +34,9 @@ rsync --recursive \
--progress \
-e "ssh " \
${WORKDIR}/staging \
- ${PARABOLAHOST}:/home/parabolavnx/${LIBREDESTDIR} || exit 1
-
-cat <<EOM
-From: you
-To: packages@list.parabolagnulinux.org
-Subject: [$pkgbase] $pkgver-$pkgrel staged on [${repos[@]}]
+ ${PARABOLAHOST}:${LIBREDESTDIR} || exit 1
-:)
-EOM
+echo ":: Removing packages from local [staging]"
+find ${WORKDIR}/staging/ -iname "*.pkg.tar.*" -delete
exit 0