summaryrefslogtreecommitdiff
path: root/librerepkg
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-10-19 15:18:07 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-10-19 15:18:07 -0300
commit7ce7ee03ad70cc246c5ccba549d8edfdc69c0ff6 (patch)
tree025a7670911e944be8652914e8d93c5efe1f1ec4 /librerepkg
parent73f4d0e6498dd590f0181ac8c1c2015d29ad168d (diff)
Added clarification for makepkg flags use
Diffstat (limited to 'librerepkg')
-rwxr-xr-xlibrerepkg5
1 files changed, 3 insertions, 2 deletions
diff --git a/librerepkg b/librerepkg
index 647a7c0..706b603 100755
--- a/librerepkg
+++ b/librerepkg
@@ -36,7 +36,7 @@ source rePKGBUILD
usage() {
echo "cd to a dir with a rePKGBUILD and other file info and run"
- echo "$0 "
+ echo "$0 [makepkg flags]"
echo
echo "This script will repackage an arch package without compiling"
}
@@ -44,6 +44,7 @@ usage() {
while getopts 'h' arg; do
case $arg in
h) usage; exit 0 ;;
+ *) makepkgflags=$@ ;;
esac
done
@@ -58,6 +59,6 @@ msg2 "Updating md5sums"
makepkg -gp rePKGBUILD >> rePKGBUILD
msg "Repackaging using makepkg"
-makepkg -Lcdp rePKGBUILD $@
+makepkg -Lcdp rePKGBUILD ${makepkgflags}
stdnull popd ${tempdir}