summaryrefslogtreecommitdiff
path: root/librerepkg
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-07 00:17:08 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-07 00:17:08 -0500
commite9bc885c355babf7851de31db8e1920dde752993 (patch)
treefd39b7d6401ead53942f66bfc4219a06f386a23f /librerepkg
parentc74d072dc83c5e3b3d9462678884cd0411a7d1d0 (diff)
organize the files
Diffstat (limited to 'librerepkg')
-rwxr-xr-xlibrerepkg72
1 files changed, 0 insertions, 72 deletions
diff --git a/librerepkg b/librerepkg
deleted file mode 100755
index d506003..0000000
--- a/librerepkg
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/bash
-# Copyright 2011 Joshua Ismael Haase Hernandez
-
-# ---------- GNU General Public License 3 ----------
-
-# This file is part of Parabola.
-
-# Parabola is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-
-# Parabola is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-
-# You should have received a copy of the GNU General Public License
-# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-
-source /etc/libretools.conf
-custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
-if [ -x $custom_config ]; then
- source $custom_config;
- unset $custom_config
-fi
-
-[[ ! -r rePKGBUILD ]] && {
- error "This build does not contains a rePKGBUILD."
- exit 1
-}
-
-source /etc/makepkg.conf
-source /etc/abs.conf
-source rePKGBUILD
-
-usage() {
- echo "cd to a dir with a rePKGBUILD and other file info and run"
- echo "$0 [makepkg flags]"
- echo
- echo "This script will repackage an arch package without compiling"
-}
-
-while getopts 'h' arg; do
- case $arg in
- h) usage; exit 0 ;;
- esac
-done
-
-makepkgflags=$@
-
-tempdir=$(mktemp -d /tmp/$(basename $PWD).XXXXX)
-
-msg "Copying files"
-cp ./* ${tempdir}/
-
-for _arch in ${arch[@]}; do
-
- msg "Repackaging: $pkgname $pkgver-$pkgrel ($(date -u))"
-
- stdnull pushd ${tempdir}
-
- msg2 "Updating md5sums"
- makepkg -gp rePKGBUILD >> rePKGBUILD
-
- echo "export CARCH=${_arch}" >> rePKGBUILD
-
- msg "Repackaging using makepkg"
- makepkg -Lcdp rePKGBUILD ${makepkgflags}
-
- stdnull popd ${tempdir}
-done