summaryrefslogtreecommitdiff
path: root/librestage
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2011-02-08 22:35:05 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2011-02-08 22:35:05 -0300
commitb279674cdc555740efcc4bebee642467226add6b (patch)
tree08ca5910a1688f4c24ca7b9a4b57914410c39871 /librestage
parentf874a3af8b0f3d32b26dcfa4a8b57b4220e3851f (diff)
Removed extra space from license messages
Diffstat (limited to 'librestage')
-rwxr-xr-xlibrestage89
1 files changed, 89 insertions, 0 deletions
diff --git a/librestage b/librestage
new file mode 100755
index 0000000..2ac8adc
--- /dev/null
+++ b/librestage
@@ -0,0 +1,89 @@
+#!/bin/bash
+# LibreStage
+# Prepares packages for upload into [staging]
+
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+source /etc/libretools.conf
+custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
+[[ -e $custom_config ]] && source $custom_config
+
+# End Config
+
+usage() {
+ cat <<EOU
+LibreStage Copyright (C) 2011 Nicolás Reynolds
+This program comes with ABSOLUTELY NO WARRANTY.
+This is free software, and you are welcome to redistribute it
+under the terms of the GNU General Public License version 3 or later.
+
+
+Usage: $(basename $0) <repo> [<repo2> ... ]
+
+LibreRelease will stage for upload the package(s) built by the PKGBUILD on
+the current directory to the specified repo(s).
+EOU
+}
+
+repos=$@
+
+if [ ${#repos} -eq 0 ]; then
+ usage
+ exit 1;
+fi
+
+[[ ! -e ./PKGBUILD ]] && {
+ echo "PKGBUILD not found"
+ exit 1
+}
+
+# Source the needed files
+source PKGBUILD
+source /etc/makepkg.conf
+[[ -e ~/.makepkg.conf ]] && source ~/.makepkg.conf
+
+# Default package location
+PKGDEST=${PKGDEST:-.}
+SRCPKGDEST=${SRCPKGDEST:-.}
+
+# Copies the packages to the specified repos inside staging
+for _arch in ${arch[@]}; do
+ for pkg in ${pkgname[@]}; do
+
+ pkgfile="$PKGDEST/$pkg-$pkgver-$pkgrel-$_arch$PKGEXT"
+
+ if [ -e "${pkgfile}" ]; then
+
+ for _repo in ${repos[@]}; do
+
+ cp "${pkgfile}" "${WORKDIR}/staging/${_repo}/" || {
+ echo "Can't put ${pkgfile} on [staging]"
+ exit 1
+ }
+
+ done
+
+ fi
+ done
+done
+
+echo "${pkgname[@]} staged on [${repos[@]}]"
+
+exit 0