summaryrefslogtreecommitdiff
path: root/librestage
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-05-16 10:22:09 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-05-16 10:22:09 -0500
commit1b59d6008a5a47969f3395ac7d68e1c0c22dcf43 (patch)
tree0a7e0ef16f8e41abb9b45b9f08241ec9e7ab44c9 /librestage
parent7f118f53283d7e228c40a40076815ce94ebb94a7 (diff)
librestage to use arch from pkgbuild
librerelease to print nice format
Diffstat (limited to 'librestage')
-rwxr-xr-xlibrestage12
1 files changed, 9 insertions, 3 deletions
diff --git a/librestage b/librestage
index fa72098..498801b 100755
--- a/librestage
+++ b/librestage
@@ -44,6 +44,12 @@ EOU
repos=$@
+while getopts 'h' arg; do
+ case $arg in
+ h) usage; exit 0 ;;
+ esac
+done
+
if [ ${#repos} -eq 0 ]; then
usage
exit 1;
@@ -55,10 +61,10 @@ fi
}
# Source the needed files
-source ./PKGBUILD
-[[ -e ./rePKGBUILD ]] && source ./rePKGBUILD
source /etc/makepkg.conf
[[ -e ~/.makepkg.conf ]] && source ~/.makepkg.conf
+source ./PKGBUILD
+[[ -e ./rePKGBUILD ]] && source ./rePKGBUILD
# Default package location
PKGDEST=${PKGDEST:-.}
@@ -67,7 +73,7 @@ SRCPKGDEST=${SRCPKGDEST:-.}
PKGEXT=".pkg.tar.?z"
# Copies the packages to the specified repos inside staging
-for _arch in ${ARCHES[@]}; do
+for _arch in ${arch[@]}; do
for pkg in ${pkgname[@]}; do
pkgpath=$(find ${PKGDEST}/ -type f -name "${pkg}-${pkgver}-${pkgrel}-${_arch}${PKGEXT}")