summaryrefslogtreecommitdiff
path: root/librestage
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-02-09 12:57:33 -0600
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-02-09 12:57:33 -0600
commit52adb1bbd654504bd00ef6ec25fc85e8f51c130a (patch)
treef7846c7d19a301ac50aad7360b9523247c100f49 /librestage
parent3b84550f01e3c226e6dd43a01a21d2b1e121f252 (diff)
Modified librestage to be more informative (when I tried it, it said «libretools staged on [core]» but nothing had happened)
Diffstat (limited to 'librestage')
-rwxr-xr-xlibrestage13
1 files changed, 6 insertions, 7 deletions
diff --git a/librestage b/librestage
index 2ac8adc..933a7e7 100755
--- a/librestage
+++ b/librestage
@@ -55,7 +55,7 @@ fi
}
# Source the needed files
-source PKGBUILD
+source ./PKGBUILD
source /etc/makepkg.conf
[[ -e ~/.makepkg.conf ]] && source ~/.makepkg.conf
@@ -70,20 +70,19 @@ for _arch in ${arch[@]}; do
pkgfile="$PKGDEST/$pkg-$pkgver-$pkgrel-$_arch$PKGEXT"
if [ -e "${pkgfile}" ]; then
-
+ echo found ${pkgfile}
for _repo in ${repos[@]}; do
cp "${pkgfile}" "${WORKDIR}/staging/${_repo}/" || {
echo "Can't put ${pkgfile} on [staging]"
exit 1
- }
-
+ } && {
+ echo "${pkg} staged on [${_repo}]"
+ }
done
fi
done
done
-echo "${pkgname[@]} staged on [${repos[@]}]"
-
-exit 0
+exit 0 \ No newline at end of file