summaryrefslogtreecommitdiff
path: root/librestage
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-03-25 07:09:23 -0700
committerJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-03-25 07:09:23 -0700
commit691baba22e7fb1fe47005558ca92e540566fe383 (patch)
tree8fc6367afbe472c51664ff2edf0310715b8712dd /librestage
parent5f47cf2a8f096f284bb1a9278fa676960ae65847 (diff)
Added libremessages and format in scripts
Diffstat (limited to 'librestage')
-rwxr-xr-xlibrestage12
1 files changed, 6 insertions, 6 deletions
diff --git a/librestage b/librestage
index 70aaa4a..f75d101 100755
--- a/librestage
+++ b/librestage
@@ -50,7 +50,7 @@ if [ ${#repos} -eq 0 ]; then
fi
[[ ! -e ./PKGBUILD ]] && {
- echo "PKGBUILD not found"
+ error "PKGBUILD not found"
exit 1
}
@@ -70,7 +70,7 @@ for _arch in ${arch[@]}; do
pkgpath="$PKGDEST/$pkgfile"
if [ -e "${pkgpath}" ]; then
- echo found ${pkgfile}
+ msg "Found ${pkgfile}"
canonical=""
for _repo in ${repos[@]}; do
@@ -78,17 +78,17 @@ for _arch in ${arch[@]}; do
[[ -z "$canonical" ]] && {
canonical="${WORKDIR}/staging/${_repo}/${pkgfile}"
cp "${pkgpath}" "${WORKDIR}/staging/${_repo}/" || {
- echo "Can't put ${pkgfile} on [staging]"
+ error "Can't put ${pkgfile} on [staging]"
exit 1
} && {
- echo "${pkg} staged on [${_repo}]"
+ msg2 "${pkg} staged on [${_repo}]"
}
} || {
ln "${canonical}" "${WORKDIR}/staging/${_repo}/${pkgfile}" || {
- echo "Can't put ${pkgfile} on [staging]"
+ error "Can't put ${pkgfile} on [staging]"
exit 1
} && {
- echo "${pkg} staged on [${_repo}]"
+ msg2 "${pkg} staged on [${_repo}]"
}
}
done