summaryrefslogtreecommitdiff
path: root/librestage
diff options
context:
space:
mode:
authorNicolas Reynolds <fauno@kiwwwi.com.ar>2011-05-01 22:47:56 -0300
committerNicolas Reynolds <fauno@kiwwwi.com.ar>2011-05-01 22:47:56 -0300
commitc0bb90f5818ae2c5d40f125f3c5982b92358c68c (patch)
tree8c1dda846c382a234f717822b4b5b72b01fbe0a2 /librestage
parenta3204e055fb538cdca56fc477d264c6d46e72ca3 (diff)
Fixed way of finding packages on librestage. Also it just searchs for ARCHES
instead of PKGBUILD architectures. Added 'any' to libretools.conf
Diffstat (limited to 'librestage')
-rwxr-xr-xlibrestage12
1 files changed, 9 insertions, 3 deletions
diff --git a/librestage b/librestage
index 6d7b45e..fa72098 100755
--- a/librestage
+++ b/librestage
@@ -64,11 +64,17 @@ source /etc/makepkg.conf
PKGDEST=${PKGDEST:-.}
SRCPKGDEST=${SRCPKGDEST:-.}
+PKGEXT=".pkg.tar.?z"
+
# Copies the packages to the specified repos inside staging
-for _arch in ${arch[@]}; do
+for _arch in ${ARCHES[@]}; do
for pkg in ${pkgname[@]}; do
- pkgfile="$pkg-$pkgver-$pkgrel-$_arch$PKGEXT"
- pkgpath="$PKGDEST/$pkgfile"
+
+ pkgpath=$(find ${PKGDEST}/ -type f -name "${pkg}-${pkgver}-${pkgrel}-${_arch}${PKGEXT}")
+
+ [[ -z ${pkgpath} ]] && continue;
+
+ pkgfile=$(basename ${pkgpath})
if [ -e "${pkgpath}" ]; then
msg "Found ${pkgfile}"