summaryrefslogtreecommitdiff
path: root/libretools.conf
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2011-02-05 12:53:02 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2011-02-05 12:53:02 -0300
commit44c866b682642e09d5de1c2ffdfe9928e51d8772 (patch)
tree35c8e5a6ed2f7cc5e11b3b7d802c57b86cb8df4b /libretools.conf
parent62d480116033b09540fe62d32c9ee3da720f35e0 (diff)
CreateWorkDir creates the dir tree for packaging
Diffstat (limited to 'libretools.conf')
-rw-r--r--libretools.conf20
1 files changed, 17 insertions, 3 deletions
diff --git a/libretools.conf b/libretools.conf
index 47f268a..00cbb28 100644
--- a/libretools.conf
+++ b/libretools.conf
@@ -1,6 +1,14 @@
## Blacklist URL
BLACKLIST=http://repo.parabolagnulinux.org/docs/blacklist.txt
+# The dir where you work on
+WORKDIR=/home/$USER/packages
+# The repos you'll be packaging for
+REPOS=('libre' 'libre-testing')
+
+# The architectures
+ARCHES=('i686' 'x86_64')
+
## The directory where the chroots are stored
CHROOTDIR=/home/chroot
@@ -13,15 +21,18 @@ CHCOPY=copy
CACHEDIR=`grep "^#\?CacheDir" /etc/pacman.conf | cut -d'=' -f2`
## Directory where you store PKGBUILD patches
-PATCHDIR=
+PATCHDIR=${WORKDIR}/abslibre/patches
## Parabola hostname (should be the same used on ssh_config
PARABOLAHOST=parabola
## Server destination of libre packages
-LIBREDESTDIR=parabolagnulinux.org/repo/staging
+LIBREDESTDIR=parabolagnulinux.org/free/staging
LIBRESRCDIR=parabolagnulinux.org/repo/pkgbuilds
+## ABSLibre
+ABSLIBREGIT=http://projects.parabolagnulinux.org/abslibre.git/
+
# Recommended SSH Config
# SSH host, it's better if you have it configured on ~/.ssh/config
# with ControlMaster auto (and a shell opened somewhere else)
@@ -44,7 +55,10 @@ LIBRESRCDIR=parabolagnulinux.org/repo/pkgbuilds
# Checks if vars aren't empty
-for VAR in CHROOTDIR CHROOT CHCOPY CACHEDIR PARABOLAHOST LIBREDESTDIR LIBRESRCDIR; do
+#
+for VAR in CHROOTDIR CHROOT CHCOPY CACHEDIR PARABOLAHOST LIBREDESTDIR
+ LIBRESRCDIR BLACKLIST WORKDIR PATCHDIR REPOS ARCHES ABSLIBREGIT; do
+
[[ -z ${!VAR} ]] && {
echo "Configure $VAR var in $0"
exit 1