summaryrefslogtreecommitdiff
path: root/libretools.install
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2010-10-19 19:46:57 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2010-10-19 19:46:57 -0500
commit4ecf6b27871b4384fc6ff66f46870f3e6f850ec6 (patch)
tree56b61953a7e7c34ad3abdc35f020d86a20ce821d /libretools.install
parent04f0c6e4d8f280ea39d1a062d47214cca5359ff3 (diff)
Updated install script to give instructions, and PKGBUILDv20101019
Diffstat (limited to 'libretools.install')
-rw-r--r--libretools.install40
1 files changed, 30 insertions, 10 deletions
diff --git a/libretools.install b/libretools.install
index 36848f0..41305ee 100644
--- a/libretools.install
+++ b/libretools.install
@@ -1,15 +1,35 @@
+
# arg 1: the new package version
post_install() {
- echo "Edit /etc/libretools.conf to fit your needs"
- echo ""
- echo "For the scripts that can be run as normal user you can make"
- echo "custom configuration by copying /etc/libretools.conf to"
- echo "\$XDG_CONFIG_HOME/libretools/libretools.conf"
- echo ""
- echo "Your /etc/pacman.conf should have uncommented CacheDir option"
-}
+ cat <<EOF
+
+For using libremakepkg /etc/libretools.conf to fit your needs.
+
+For the scripts that can be run as normal user you can make
+custom configuration by copying /etc/libretools.conf to
+\$XDG_CONFIG_HOME/libretools/libretools.conf
+
+Your /etc/pacman.conf should have uncommented CacheDir option
+
+You should add this to your ~/.ssh/config file:
-# arg 1: the old package version
-post_remove() {
+# Parabola Host
+Host parabola
+ Port 22
+ HostName parabolagnulinux.org
+ User parabolavnx
+ IdentityFile ~/.ssh/id_dsa
+# End Parabola Host
+Edit IdentityFile as needed.
+
+EOF
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install
}
+
+# vim:set ts=2 sw=2 et: