summaryrefslogtreecommitdiff
path: root/pkgbuild-check-nonfree
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2010-10-16 17:15:32 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2010-10-16 17:15:32 -0500
commit6273f6806f209677cee954f6a211167b62d1a7ca (patch)
treec3fc79355d0926f2f2e686eef504a187cfdfa063 /pkgbuild-check-nonfree
parent9880e8839a9ea27f2b8f5df21e52a7f1199a4546 (diff)
Agregado .gitignore y pkgbuild-check-nonfree
Diffstat (limited to 'pkgbuild-check-nonfree')
-rwxr-xr-xpkgbuild-check-nonfree61
1 files changed, 61 insertions, 0 deletions
diff --git a/pkgbuild-check-nonfree b/pkgbuild-check-nonfree
new file mode 100755
index 0000000..8b04733
--- /dev/null
+++ b/pkgbuild-check-nonfree
@@ -0,0 +1,61 @@
+#!/bin/bash
+# pkgbuild-check-nonfree
+# Copyright 2010 Joshua Ismael Haase Hernández
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+dir=$(pwd)
+tempdir=$(mktemp -d)
+cd $tempdir
+
+# Run a sanity check
+which pacman wget >/dev/null 2>/dev/null || {
+ echo "Cannot find pacman or wget, exiting";
+ exit 1
+}
+
+echo "Downloading the blacklist of proprietary software packages."
+echo ""
+wget http://www.parabolagnulinux.org/docs/blacklist.txt 2>/dev/null || {
+ echo "Download failed, exiting"
+ exit 1
+}
+
+a=($(cut -d: -f1 blacklist.txt))
+source /etc/rc.d/functions
+source $dir/PKGBUILD
+
+echo "Looking for non-free dependancies:"
+
+echo "Found in «depends»:"
+for item in ${depends[@]} ; do
+ if in_array $item ${a[@]}; then
+ echo $item
+ fi
+done
+
+echo "Found in «makedepends»:"
+for item in ${makedepends[@]}; do
+ if in_array $item ${a[@]}; then
+ echo $item
+ fi
+done
+
+rm -rf $tempdir
+exit 0
+