summaryrefslogtreecommitdiff
path: root/pkgbuild-check-nonfree
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-03-25 07:09:23 -0700
committerJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-03-25 07:09:23 -0700
commit691baba22e7fb1fe47005558ca92e540566fe383 (patch)
tree8fc6367afbe472c51664ff2edf0310715b8712dd /pkgbuild-check-nonfree
parent5f47cf2a8f096f284bb1a9278fa676960ae65847 (diff)
Added libremessages and format in scripts
Diffstat (limited to 'pkgbuild-check-nonfree')
-rwxr-xr-xpkgbuild-check-nonfree14
1 files changed, 7 insertions, 7 deletions
diff --git a/pkgbuild-check-nonfree b/pkgbuild-check-nonfree
index 418a0bf..6f3837b 100755
--- a/pkgbuild-check-nonfree
+++ b/pkgbuild-check-nonfree
@@ -30,14 +30,14 @@ ev=0
# Check if the blacklist variable is empty, and if so error.
[[ ${#BLACKLIST} -eq 0 ]] && {
- echo "Please set up the BLACKLIST variable in your libretools.conf file"
+ error "BLACKLIST variable is not set your libretools.conf file"
exit 1
}
# Download the blacklist.
-echo "Downloading the blacklist of proprietary software packages."
+msg "Downloading the blacklist of proprietary software packages."
wget -N -q -O blacklist.txt "${BLACKLIST}" 2>/dev/null || {
- echo "Download failed, exiting"
+ error "Download failed, exiting"
exit 1
}
@@ -55,9 +55,9 @@ source ./PKGBUILD
# The `pkgname', `depends', `makedepends' arrays have been sourced from
# ./PKGBUILD.
-echo "Looking for unfree dependencies"
+msg "Looking for unfree dependencies"
for where in pkgname depends makedepends ; do
- echo " Found in «${where}»:"
+ msg2 " Cheking in «${where}»:"
# We cycle through all of the programs in the array (if any), and check if
# they are in the `unfree' array.
@@ -65,9 +65,9 @@ for where in pkgname depends makedepends ; do
if in_array $item ${unfree[@]}
then
ev=15
- echo $item
+ plain $item
fi
done
done
-exit $ev
+exit $ev \ No newline at end of file