summaryrefslogtreecommitdiff
path: root/po/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-07-08 22:08:04 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-07-08 22:08:04 -0400
commitbcc12b176fc19070aa16940ff4840830bc2ecd59 (patch)
treed106ea6a95d4fa20d8ccfce16d797df4ba425d9b /po/Makefile
parentafc6093ea5b87d2d4c870cef7ef66548d3d576ba (diff)
Makefile: add support for compiling and installing localizations
This means that the new `po/files.generate` target can be used to build the `.pot` files without doing anything else; we can stop requiring translators to install ruby-ronn. It also means that we can put the `.pot` files in the source tarball, to make it even easier for translators. Unfortunately, it does add the extra step of having to create another symlink when adding a new locale.
Diffstat (limited to 'po/Makefile')
-rw-r--r--po/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/po/Makefile b/po/Makefile
new file mode 100644
index 0000000..1e56edd
--- /dev/null
+++ b/po/Makefile
@@ -0,0 +1,11 @@
+include $(dir $(lastword $(MAKEFILE_LIST)))/../config.mk
+include $(topsrcdir)/build-aux/Makefile.head.mk
+
+domains = libretools librelib gitget xbs
+locales := $(filter-out .,$(sort $(patsubst %/,%,$(dir $(files.src.src)))))
+
+files.src.gen += $(addsuffix .pot,$(domains))
+nested.subdirs += $(locales)
+at.subdirs += ..
+
+include $(topsrcdir)/build-aux/Makefile.tail.mk