summaryrefslogtreecommitdiff
path: root/po/subdir.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-03-27 19:44:34 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-03-27 21:27:19 -0400
commit086df91f23d1f3486725353ffe1630da8f9c8f5c (patch)
treec583bb8b5ffcfd915b02a44ef9799bd47f2bbbc5 /po/subdir.mk
parent36f875645e36bf1ff015cc7d3441de2e1714b6fc (diff)
Makefile: Use files.groups instead of nested.subdirs to split the package
Diffstat (limited to 'po/subdir.mk')
-rw-r--r--po/subdir.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/po/subdir.mk b/po/subdir.mk
index b9a2575..9d07d3c 100644
--- a/po/subdir.mk
+++ b/po/subdir.mk
@@ -11,8 +11,12 @@ $(outdir)/%.mo: $(srcdir)/%.po $(call at.path,$(srcdir)/../%.pot)
$(DESTDIR)$(localedir)/$(locale)/LC_MESSAGES/%.mo: $(outdir)/%.mo
install -T -Dm644 '$<' '$@'
-files.out.all += $(addsuffix .mo,$(domains))
-files.sys.all += $(foreach domain,$(domains),$(localedir)/$(locale)/LC_MESSAGES/$(domain).mo)
+define _domain_rule
+files.out.$(domain) += $(domain).mo
+files.sys.$(domain) += $(localedir)/$(locale)/LC_MESSAGES/$(domain).mo
+endef
+$(eval $(foreach domain,$(domains),$(_domain_rule)$(at.nl)))
+
at.subdirs += ..
include $(topsrcdir)/build-aux/Makefile.tail.mk