summaryrefslogtreecommitdiff
path: root/po
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2017-07-29 21:59:30 -0400
committerDavid P <megver83@parabola.nu>2017-07-29 21:59:30 -0400
commit5e9742f03e4199c006b0f9d0d8069a2fb41d9258 (patch)
treec5e7c30625b30b50a2a2385ef934c1d7e57eb2fa /po
parent63f4ac3c0a6ea7e060720b63964cf158157fc785 (diff)
parent0b8606e0cd0e1aedfe222d4d6603c4986aacb7b5 (diff)
Merge branch 'master' of ssh://git.parabola.nu:1863/~git/packages/libretools
Diffstat (limited to 'po')
-rw-r--r--po/.gitignore3
-rw-r--r--po/HACKING19
-rw-r--r--po/Makefile21
l---------po/es/Makefile1
-rw-r--r--po/es/gitget.po22
-rw-r--r--po/es/librelib.po29
-rw-r--r--po/es/libretools.po83
-rw-r--r--po/es/xbs.po50
-rw-r--r--po/header.po.head.in14
-rw-r--r--po/subdir.mk18
10 files changed, 225 insertions, 35 deletions
diff --git a/po/.gitignore b/po/.gitignore
index e3a8c5d..406ef00 100644
--- a/po/.gitignore
+++ b/po/.gitignore
@@ -1 +1,2 @@
-*.pot
+*.mo
+/header.po.head
diff --git a/po/HACKING b/po/HACKING
index 2a29adc..5dd207c 100644
--- a/po/HACKING
+++ b/po/HACKING
@@ -2,19 +2,24 @@ Translations for programs are provided in files with the `.po` suffix.
These are created by copying PO-template (`.pot`) files, and filling
in the missing "msgstr" values.
-To add a translation, you'll first (1) need to create the `.pot`
-files, and then (2) copy them and (3) fill them in.
+To add a translation, you'll first (1) need to create the `.pot` files
+if you don't already have them, and then (2) copy them and (3) fill
+them in.
# 1. Create `.pot` files
+ If you are working from a release source tarball, you can skip this
+ step (the `.pot` files are included in the tarball); if you are
+ working from git, read on.
+
libretools' .pot files are not tracked in git; they are created by
- running `make` (you'll need a checkout of both devtools-par and
- libretools to run `make` if building from git):
+ running `make`. You'll need a checkout of both "devtools-par" and
+ "libretools" to run `make` if building from git.
$ git clone https://git.parabola.nu/packages/devtools-par.git/
$ git clone https://git.parabola.nu/packages/libretools.git/
$ cd libretools
- $ make
+ $ make po/files.generate
...
$ cd po/
$ ls
@@ -29,10 +34,12 @@ files, and then (2) copy them and (3) fill them in.
Create a folder under `po/` with the two-letter language code[^1]
you want to add. Then, copy the `.pot` files to that folder,
- changing the file extension to `.po`; for example:
+ changing the file extension to `.po`. Finally, link the `subdir.mk`
+ file to be the Makefile for that directory. For example:
$ mkdir es
$ for file in *.pot; do cp $file es/${file%t}; done
+ $ ln -s ../subdir.mk es/Makefile
[^1]: See the langauge code table
here: <http://www.lingoes.net/en/translator/langcode.htm>
diff --git a/po/Makefile b/po/Makefile
new file mode 100644
index 0000000..96d8490
--- /dev/null
+++ b/po/Makefile
@@ -0,0 +1,21 @@
+include $(dir $(lastword $(MAKEFILE_LIST)))/../config.mk
+include $(topsrcdir)/build-aux/Makefile.head.mk
+
+domains = libretools librelib gitget xbs
+locales := $(filter-out .,$(sort $(patsubst %/,%,$(dir $(files.src.src)))))
+
+files.src.gen += $(addsuffix .pot,$(domains))
+nested.subdirs += $(locales)
+
+# Have the header include the version number
+$(srcdir)/header.po.head: $(srcdir)/%: $(srcdir)/%.in
+ @echo 'EDIT < $< > $@'; $(libretools.edit) < '$<' > '$@'
+$(srcdir)/header.po.head: $(var.)PACKAGE $(var.)VERSION
+files.src.int += header.po.head
+
+# Rely on ../Makefile to fill in a list of our .pot dependencies
+$(srcdir)/%.pot: $(srcdir)/header.po.head
+ cat $^ | msguniq -Fi > '$@'
+at.subdirs += ..
+
+include $(topsrcdir)/build-aux/Makefile.tail.mk
diff --git a/po/es/Makefile b/po/es/Makefile
new file mode 120000
index 0000000..71a1159
--- /dev/null
+++ b/po/es/Makefile
@@ -0,0 +1 @@
+../subdir.mk \ No newline at end of file
diff --git a/po/es/gitget.po b/po/es/gitget.po
index f248569..723fc90 100644
--- a/po/es/gitget.po
+++ b/po/es/gitget.po
@@ -1,3 +1,18 @@
+# Copyright (C) 2017 David P <megver83@parabola.nu>
+# This file is distributed under the same license as the libretools package.
+#
+msgid ""
+msgstr "Project-Id-Version: libretools 20170705\n"
+ "Report-Msgid-Bugs-To: Parabola Hackers <dev@lists.parabola.nu>\n"
+ "PO-Revision-Date: 2017-07-05 19:27-0400\n"
+ "Last-Translator: David P <megver83@parabola.nu>\n"
+ "Language-Team: Spanish\n"
+ "Language: es\n"
+ "MIME-Version: 1.0\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Content-Transfer-Encoding: 8bit\n"
+ "Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
#: src/gitget/gitget:35
msgid "Failed to change to directory %s"
msgstr "Falló al cambiar el directorio %s"
@@ -84,6 +99,11 @@ msgstr "En lugar de comprobar que las URL configuradas coinciden, forzar la "
msgid "URL"
msgstr "URL"
+#: src/gitget/gitget:178
+msgid "In addition to setting or checking `remotes.origin.url`, also set or "
+ "check `remotes.origin.pushUrl`"
+msgstr ""
+
#: src/gitget/gitget:180
msgid "NAME"
msgstr "NOMBRE"
@@ -112,7 +132,7 @@ msgid "This exists because gitget used to be called libregit, and took the "
"floating around that use it."
msgstr "Esto existe porque gitget solía llamarse libregit, y tomó los "
"argumentos en este formato, y estoy seguro de que hay unos cuantos scripts "
- "flotando alrededor que lo usan".
+ "flotando alrededor que lo usan."
#: src/gitget/libregit:30
msgid "Clones or pulls from the git URL '<REPO>', and checks out the git "
diff --git a/po/es/librelib.po b/po/es/librelib.po
index ff4c460..7205775 100644
--- a/po/es/librelib.po
+++ b/po/es/librelib.po
@@ -1,3 +1,18 @@
+# Copyright (C) 2017 David P <megver83@parabola.nu>
+# This file is distributed under the same license as the libretools package.
+#
+msgid ""
+msgstr "Project-Id-Version: libretools 20170705\n"
+ "Report-Msgid-Bugs-To: Parabola Hackers <dev@lists.parabola.nu>\n"
+ "PO-Revision-Date: 2017-07-05 20:02-0400\n"
+ "Last-Translator: David P <megver83@parabola.nu>\n"
+ "Language-Team: Spanish\n"
+ "Language: es\n"
+ "MIME-Version: 1.0\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Content-Transfer-Encoding: 8bit\n"
+ "Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
#: src/lib/archroot.sh:62
msgid "Unable to delete subvolume %s"
msgstr "Incapaz de eliminar subvolumen %s"
@@ -27,7 +42,7 @@ msgstr "Imprime el blacklist"
msgid "Uses the cache, but downloads it if it doesn't exist. Also "
"normalizes the blacklist for easier parsing."
msgstr "Utiliza el caché, pero la descarga si no existe. También "
- "normaliza la lista negra para facilitar el análisis sintáctico".
+ "normaliza la lista negra para facilitar el análisis sintáctico."
#. embedded usage text
#: src/lib/blacklist.sh:42
@@ -232,11 +247,19 @@ msgstr "Dishabilita el uso de las palabras clave predeterminadas"
msgid "Show this text"
msgstr "Muestra este texto"
-#: src/lib/librexgettext:205
+#: src/lib/librexgettext:177 src/lib/librexgettext:224
+msgid "flag error: Missing expected flag meaning at argument %d"
+msgstr ""
+
+#: src/lib/librexgettext:196
+msgid "flag error: Jumped from argument %d to %d"
+msgstr ""
+
+#: src/lib/librexgettext:255
msgid "unrecognized option: %s"
msgstr "opción no reconocida: %s"
-#: src/lib/librexgettext:211
+#: src/lib/librexgettext:261
msgid "no input file given"
msgstr "no se ha dado ningún archivo"
diff --git a/po/es/libretools.po b/po/es/libretools.po
index 55bedb2..67fe6de 100644
--- a/po/es/libretools.po
+++ b/po/es/libretools.po
@@ -1,3 +1,18 @@
+# Copyright (C) 2017 David P <megver83@parabola.nu>
+# This file is distributed under the same license as the libretools package.
+#
+msgid ""
+msgstr "Project-Id-Version: libretools 20170705\n"
+ "Report-Msgid-Bugs-To: Parabola Hackers <dev@lists.parabola.nu>\n"
+ "PO-Revision-Date: 2017-07-06 13:59-0400\n"
+ "Last-Translator: David P <megver83@parabola.nu>\n"
+ "Language-Team: Spanish\n"
+ "Language: es\n"
+ "MIME-Version: 1.0\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Content-Transfer-Encoding: 8bit\n"
+ "Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
#: src/abslibre-tools/createworkdir:36
msgid "Creating WORKDIR at %s..."
msgstr "Creando WORKDIR en %s..."
@@ -15,7 +30,7 @@ msgid "Finished, your packaging directory tree looks like this now:"
msgstr "Terminado, su árbol de directorio de empaquetado es así ahora:"
#: src/abslibre-tools/diff-unfree:30
-msgid "Usage: %s [community|packages] [paquete-no-libre] [repo]"
+msgid "Usage: %s [community|packages] [unfree-package] [repo]"
msgstr "Uso: %s [community|packages] [paquete-no-libre] [repo]"
#: src/abslibre-tools/diff-unfree:31
@@ -704,6 +719,10 @@ msgstr "Crear una copia, eliminar una copia o sincronizar una copia puede ser b
msgid "CHROOT"
msgstr "CHROOT"
+#: src/chroot-tools/librechroot:253 src/chroot-tools/libremakepkg:162
+msgid "Name of the chroot to use"
+msgstr ""
+
#: src/chroot-tools/librechroot:254 src/chroot-tools/libremakepkg:163
msgid "COPY"
msgstr "COPIA"
@@ -716,6 +735,10 @@ msgstr "Nombre, o ruta absoluta, de la copia a utilizar"
msgid "Disable networking in the chroot"
msgstr "Deshabilitar la conexión de redes en el chroot"
+#: src/chroot-tools/librechroot:256
+msgid "Copy this file to `$copydir/etc/pacman.conf`"
+msgstr ""
+
#: src/chroot-tools/librechroot:256 src/chroot-tools/librechroot:257
#: src/librefetch/librefetch:84
msgid "FILE"
@@ -729,7 +752,12 @@ msgstr "Copia este archivo a `$copydir/etc/makepkg.conf`"
msgid "CARCH"
msgstr "CARCH"
-#: src/chroot-tools/librechroot:260
+#: src/chroot-tools/librechroot:258
+msgid "Set the architecture of the copy; simply an alias for the `-C` and `-"
+ "M` flags, see above."
+msgstr ""
+
+#: src/chroot-tools/librechroot:260 src/chroot-tools/libremakepkg:164
msgid "Bind mount a file or directory, read/write"
msgstr "Enlazar un archivo o directorio, lectura/escritura"
@@ -738,6 +766,10 @@ msgstr "Enlazar un archivo o directorio, lectura/escritura"
msgid "PATH[:PATH]"
msgstr "RUTA[:RUTA]"
+#: src/chroot-tools/librechroot:261 src/chroot-tools/libremakepkg:165
+msgid "Bind mount a file or directory, read-only"
+msgstr ""
+
#: src/chroot-tools/librechroot:264
msgid " Create/copy/delete:"
msgstr " Crear/copiar/eliminar"
@@ -764,6 +796,10 @@ msgstr " Lidiando con paquetes:"
msgid "FILES..."
msgstr "ARCHIVOS..."
+#: src/chroot-tools/librechroot:270
+msgid "Like `pacman -U FILES...`"
+msgstr ""
+
#: src/chroot-tools/librechroot:271
msgid "Like `pacman -S NAMES...`"
msgstr "Como `pacman -S NOMBRES...`"
@@ -792,6 +828,10 @@ msgstr " Otro:"
msgid "CMD..."
msgstr "CMD..."
+#: src/chroot-tools/librechroot:278
+msgid "Run CMD in the chroot copy"
+msgstr ""
+
#: src/chroot-tools/librechroot:279
msgid "Enter an interactive shell in the chroot copy"
msgstr "Entrar a un shell interactivo en la copia de chroot"
@@ -800,63 +840,63 @@ msgstr "Entrar a un shell interactivo en la copia de chroot"
msgid "Clean /repo in the chroot copy"
msgstr "Limpiar /repo en la copia del chroot"
-#: src/chroot-tools/librechroot:303
+#: src/chroot-tools/librechroot:306
msgid "Unsupported architecture: %s"
msgstr "Arquitectura no admitida: %s"
-#: src/chroot-tools/librechroot:321
+#: src/chroot-tools/librechroot:324
msgid "Must specify a command"
msgstr "Debe especificar un comando"
-#: src/chroot-tools/librechroot:327
+#: src/chroot-tools/librechroot:330
msgid "Unrecognized command: %s"
msgstr "Comando no reconocido: %s"
-#: src/chroot-tools/librechroot:335
+#: src/chroot-tools/librechroot:338
msgid "Command `%s` does not take any arguments: %s"
msgstr "El comando `%s` no toma ningún argumento: %s"
-#: src/chroot-tools/librechroot:342
+#: src/chroot-tools/librechroot:345
msgid "Command `%s` requires at least one file"
msgstr "El comando `%s` requiere al menos un archivo"
-#: src/chroot-tools/librechroot:354
+#: src/chroot-tools/librechroot:357
msgid "%s: file(s) not found: %s"
msgstr "%s: archivo(s) no encontrado(s): %s"
-#: src/chroot-tools/librechroot:361
+#: src/chroot-tools/librechroot:364
msgid "Command `%s` requires at least one package name"
msgstr "El comando `%s` requiere al menos un nombre de un paquete"
-#: src/chroot-tools/librechroot:368
+#: src/chroot-tools/librechroot:371
msgid "Command `%s` requires at least one argument"
msgstr "El comando `%s` requiere al menos un argumento"
-#: src/chroot-tools/librechroot:392
+#: src/chroot-tools/librechroot:394
msgid "This program must be run as root."
msgstr "Este programa debe ser ejecutado como root."
-#: src/chroot-tools/librechroot:400
+#: src/chroot-tools/librechroot:402
msgid "Input is not a TTY"
msgstr "La entrada no es un TTY"
-#: src/chroot-tools/librechroot:403
+#: src/chroot-tools/librechroot:405
msgid "Due to a bug in systemd-nspawn, redirecting stdin is not supported."
msgstr "Debido a un error en systemd-nspawn, el redireccionamiento de stdin no está soportado."
-#: src/chroot-tools/librechroot:411 src/chroot-tools/libremakepkg:266
+#: src/chroot-tools/librechroot:413 src/chroot-tools/libremakepkg:266
msgid "Waiting for existing lock on chroot copy to be released: [%s]"
msgstr "Esperando que el bloqueo existente en la copia de chroot sea liberado: [%s]"
-#: src/chroot-tools/librechroot:415
+#: src/chroot-tools/librechroot:417
msgid "Chroot copy is mounted with nosuid or noexec options: [%s]"
msgstr "La copia del chroot se monta con opciones nosuid o noexec: [%s]"
-#: src/chroot-tools/librechroot:420
+#: src/chroot-tools/librechroot:422
msgid "Creating 'root' copy for chroot [%s]"
msgstr "Creando copia 'root' para el chroot [%s]"
-#: src/chroot-tools/librechroot:426
+#: src/chroot-tools/librechroot:428
msgid "Syncing copy [%s] with root copy"
msgstr "Sincronizando copia [%s] con la copia root"
@@ -929,10 +969,6 @@ msgstr ""
msgid "Name of, or absolute path to, the chroot copy to use"
msgstr ""
-#: src/chroot-tools/libremakepkg:165
-msgid "Bind mount a file or directory, read-only"
-msgstr ""
-
#: src/chroot-tools/libremakepkg:167
msgid "Don't disable networking during build() and package(). PLEASE don't "
"use this unless you have a special reason, its use is a violation of "
@@ -1323,6 +1359,11 @@ msgstr ""
msgid "Force download mode (don't create)"
msgstr ""
+#: src/librefetch/librefetch:84
+msgid "Use an alternate build script (instead of 'PKGBUILD'). If an "
+ "SRCBUILD exists in the same directory, it is used instead"
+msgstr ""
+
#: src/librefetch/librefetch:87
msgid "Alternate modes:"
msgstr ""
diff --git a/po/es/xbs.po b/po/es/xbs.po
index 35bd7f1..729c470 100644
--- a/po/es/xbs.po
+++ b/po/es/xbs.po
@@ -1,3 +1,18 @@
+# Copyright (C) 2017 David P <megver83@parabola.nu>
+# This file is distributed under the same license as the libretools package.
+#
+msgid ""
+msgstr "Project-Id-Version: libretools 20170705\n"
+ "Report-Msgid-Bugs-To: Parabola Hackers <dev@lists.parabola.nu>\n"
+ "PO-Revision-Date: 2017-07-05 20:22-0400\n"
+ "Last-Translator: David P <megver83@parabola.nu>\n"
+ "Language-Team: Spanish\n"
+ "Language: es\n"
+ "MIME-Version: 1.0\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Content-Transfer-Encoding: 8bit\n"
+ "Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
#: src/xbs-abs/archrelease:12
msgid "Option requires an argument -- '%s'"
msgstr "Las opciones requieren un argumento -- '%s'"
@@ -94,9 +109,13 @@ msgstr "Opciones:"
msgid "BUILDSYSTEM"
msgstr "BUILDSYSTEM"
-#: src/xbs/xbs:51
-msgid "-h"
-msgstr "-h"
+#: src/xbs/xbs:49
+msgid "Use BUILDSYSTEM instead of the one configured in xbs.conf"
+msgstr ""
+
+#: src/xbs/xbs:51 src/xbs/xbs:76
+msgid "Show this message"
+msgstr ""
#: src/xbs/xbs:53
msgid "Whether a command is intended for use on a developer's box or on the "
@@ -120,6 +139,10 @@ msgstr "¿Hay cambios sin commit en `.`?"
msgid "(dev) download"
msgstr "(dev) descarga"
+#: src/xbs/xbs:61
+msgid "Download or update the tree"
+msgstr ""
+
#: src/xbs/xbs:62
msgid "(dev) release-client REPO ARCH"
msgstr "(dev) release-client REPO ARCQUITECTURA"
@@ -132,22 +155,43 @@ msgstr "Publica `.` (para las cajas de los desarrolladores)"
msgid "(srv) release-server REPO ARCH"
msgstr "(srv) release-client REPO ARCQUITECTURA"
+#: src/xbs/xbs:65
+msgid "Release `.` (for server boxes)"
+msgstr ""
+
#: src/xbs/xbs:66
msgid "(srv) unrelease PKGBASE REPO ARCH"
msgstr "(srv) unrelease PKGBASE REPO ARCQUITECTURA"
+#: src/xbs/xbs:67
+msgid "Unrelease a pkgbase"
+msgstr ""
+
#: src/xbs/xbs:68
msgid "(srv) move FROMREPO TOREPO PKGBASE"
msgstr "(srv) mover DESDEREPO AREPO PKGBASE"
+#: src/xbs/xbs:69
+msgid "Move a pkgbase from one repo to another"
+msgstr ""
+
#: src/xbs/xbs:70
msgid "(srv) releasepath PKGBASE REPO ARCH"
msgstr "(srv) rutadepublicación PKGBASE REPO ARQUITECTURA"
+#: src/xbs/xbs:71
+msgid "Print the path to the staged version of pkgbase, or exit with non-"
+ "zero if not released"
+msgstr ""
+
#: src/xbs/xbs:73
msgid "(any) name"
msgstr "(any) nombre"
+#: src/xbs/xbs:74
+msgid "Print a human-friendly version of the BUILDSYSTEM name"
+msgstr ""
+
#: src/xbs/xbs:75
msgid "(any) help"
msgstr "(any) ayuda"
diff --git a/po/header.po.head.in b/po/header.po.head.in
new file mode 100644
index 0000000..2346080
--- /dev/null
+++ b/po/header.po.head.in
@@ -0,0 +1,14 @@
+# Copyright (C) YEAR FULL NAME
+# This file is distributed under the same license as the @PACKAGE@ package.
+#
+msgid ""
+msgstr "Project-Id-Version: @PACKAGE@ @VERSION@\n"
+ "Report-Msgid-Bugs-To: Parabola Hackers <dev@lists.parabola.nu>\n"
+ "PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
+ "Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
+ "Language-Team: LANGUAGE <MAILING_LIST@ADDRESS>\n"
+ "Language: LANGCODE\n"
+ "MIME-Version: 1.0\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Content-Transfer-Encoding: 8bit\n"
+ "Plural-Forms: nplurals=2; plural=(n != 1);\n"
diff --git a/po/subdir.mk b/po/subdir.mk
new file mode 100644
index 0000000..b9a2575
--- /dev/null
+++ b/po/subdir.mk
@@ -0,0 +1,18 @@
+include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
+include $(topsrcdir)/build-aux/Makefile.head.mk
+
+locale = $(notdir $(srcdir))
+domains = $(patsubst %.po,%,$(filter %.po,$(files.src.src)))
+
+$(outdir)/%.mo: $(srcdir)/%.po $(call at.path,$(srcdir)/../%.pot)
+ msgcmp --use-untranslated $< $(word 2,$^)
+ msgfmt -c -o $@ $<
+
+$(DESTDIR)$(localedir)/$(locale)/LC_MESSAGES/%.mo: $(outdir)/%.mo
+ install -T -Dm644 '$<' '$@'
+
+files.out.all += $(addsuffix .mo,$(domains))
+files.sys.all += $(foreach domain,$(domains),$(localedir)/$(locale)/LC_MESSAGES/$(domain).mo)
+at.subdirs += ..
+
+include $(topsrcdir)/build-aux/Makefile.tail.mk