summaryrefslogtreecommitdiff
path: root/po
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-01-03 12:34:53 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2018-01-03 13:34:08 -0500
commit99ba7e29afaccb5b47ada8c2d8e0b0f98de91936 (patch)
tree98c0ed639758e95601e9e696e14fa7d8ab9fa9dc /po
parentb8c5c50d5eddd2346e579184305ecfb61d5660a8 (diff)
Makefile: don't let paths in .pot files depend on where `make` was called
Diffstat (limited to 'po')
-rw-r--r--po/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/po/Makefile b/po/Makefile
index 96d8490..b27844c 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -15,7 +15,13 @@ files.src.int += header.po.head
# Rely on ../Makefile to fill in a list of our .pot dependencies
$(srcdir)/%.pot: $(srcdir)/header.po.head
- cat $^ | msguniq -Fi > '$@'
+ @echo 'MSGCAT $^ > $@';
+ @{ \
+ cd $(topsrcdir) && \
+ for file in $(call at.relto,$(topsrcdir),$^); do \
+ sed "/^#:/s, , $${file%/*}/,g" <"$$file"; \
+ done; \
+ } | msguniq -Fi > '$@'
at.subdirs += ..
include $(topsrcdir)/build-aux/Makefile.tail.mk