summaryrefslogtreecommitdiff
path: root/po
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-07-09 20:12:32 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-07-09 20:21:36 -0400
commite3d7fbca888e07f02c5867dd1e50393247a066b7 (patch)
treeba8c5bac162127ceab0eacb2a6f33de759c62943 /po
parent371a7e29d5718cadbe7cd1830050487f60946266 (diff)
po: add pot headers
Diffstat (limited to 'po')
-rw-r--r--po/.gitignore4
-rw-r--r--po/Makefile10
-rw-r--r--po/es/gitget.po15
-rw-r--r--po/es/librelib.po15
-rw-r--r--po/es/libretools.po15
-rw-r--r--po/es/xbs.po15
-rw-r--r--po/header.po.head.in14
7 files changed, 86 insertions, 2 deletions
diff --git a/po/.gitignore b/po/.gitignore
index 514b3d0..406ef00 100644
--- a/po/.gitignore
+++ b/po/.gitignore
@@ -1,2 +1,2 @@
-*.pot
-*/*.mo
+*.mo
+/header.po.head
diff --git a/po/Makefile b/po/Makefile
index 1e56edd..96d8490 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -6,6 +6,16 @@ locales := $(filter-out .,$(sort $(patsubst %/,%,$(dir $(files.src.src)))))
files.src.gen += $(addsuffix .pot,$(domains))
nested.subdirs += $(locales)
+
+# Have the header include the version number
+$(srcdir)/header.po.head: $(srcdir)/%: $(srcdir)/%.in
+ @echo 'EDIT < $< > $@'; $(libretools.edit) < '$<' > '$@'
+$(srcdir)/header.po.head: $(var.)PACKAGE $(var.)VERSION
+files.src.int += header.po.head
+
+# Rely on ../Makefile to fill in a list of our .pot dependencies
+$(srcdir)/%.pot: $(srcdir)/header.po.head
+ cat $^ | msguniq -Fi > '$@'
at.subdirs += ..
include $(topsrcdir)/build-aux/Makefile.tail.mk
diff --git a/po/es/gitget.po b/po/es/gitget.po
index d3478f7..97f06d8 100644
--- a/po/es/gitget.po
+++ b/po/es/gitget.po
@@ -1,3 +1,18 @@
+# Copyright (C) 2017 David P <megver83@parabola.nu>
+# This file is distributed under the same license as the libretools package.
+#
+msgid ""
+msgstr "Project-Id-Version: libretools 20170705\n"
+ "Report-Msgid-Bugs-To: Parabola Hackers <dev@lists.parabola.nu>\n"
+ "PO-Revision-Date: 2017-07-05 19:27-0400\n"
+ "Last-Translator: David P <megver83@parabola.nu>\n"
+ "Language-Team: Spanish\n"
+ "Language: es\n"
+ "MIME-Version: 1.0\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Content-Transfer-Encoding: 8bit\n"
+ "Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
#: src/gitget/gitget:35
msgid "Failed to change to directory %s"
msgstr "Falló al cambiar el directorio %s"
diff --git a/po/es/librelib.po b/po/es/librelib.po
index 2a8c977..f71b087 100644
--- a/po/es/librelib.po
+++ b/po/es/librelib.po
@@ -1,3 +1,18 @@
+# Copyright (C) 2017 David P <megver83@parabola.nu>
+# This file is distributed under the same license as the libretools package.
+#
+msgid ""
+msgstr "Project-Id-Version: libretools 20170705\n"
+ "Report-Msgid-Bugs-To: Parabola Hackers <dev@lists.parabola.nu>\n"
+ "PO-Revision-Date: 2017-07-05 20:02-0400\n"
+ "Last-Translator: David P <megver83@parabola.nu>\n"
+ "Language-Team: Spanish\n"
+ "Language: es\n"
+ "MIME-Version: 1.0\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Content-Transfer-Encoding: 8bit\n"
+ "Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
#: src/lib/archroot.sh:62
msgid "Unable to delete subvolume %s"
msgstr "Incapaz de eliminar subvolumen %s"
diff --git a/po/es/libretools.po b/po/es/libretools.po
index 6add814..794051a 100644
--- a/po/es/libretools.po
+++ b/po/es/libretools.po
@@ -1,3 +1,18 @@
+# Copyright (C) 2017 David P <megver83@parabola.nu>
+# This file is distributed under the same license as the libretools package.
+#
+msgid ""
+msgstr "Project-Id-Version: libretools 20170705\n"
+ "Report-Msgid-Bugs-To: Parabola Hackers <dev@lists.parabola.nu>\n"
+ "PO-Revision-Date: 2017-07-06 13:59-0400\n"
+ "Last-Translator: David P <megver83@parabola.nu>\n"
+ "Language-Team: Spanish\n"
+ "Language: es\n"
+ "MIME-Version: 1.0\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Content-Transfer-Encoding: 8bit\n"
+ "Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
#: src/abslibre-tools/createworkdir:36
msgid "Creating WORKDIR at %s..."
msgstr "Creando WORKDIR en %s..."
diff --git a/po/es/xbs.po b/po/es/xbs.po
index 35bd7f1..880b5df 100644
--- a/po/es/xbs.po
+++ b/po/es/xbs.po
@@ -1,3 +1,18 @@
+# Copyright (C) 2017 David P <megver83@parabola.nu>
+# This file is distributed under the same license as the libretools package.
+#
+msgid ""
+msgstr "Project-Id-Version: libretools 20170705\n"
+ "Report-Msgid-Bugs-To: Parabola Hackers <dev@lists.parabola.nu>\n"
+ "PO-Revision-Date: 2017-07-05 20:22-0400\n"
+ "Last-Translator: David P <megver83@parabola.nu>\n"
+ "Language-Team: Spanish\n"
+ "Language: es\n"
+ "MIME-Version: 1.0\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Content-Transfer-Encoding: 8bit\n"
+ "Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
#: src/xbs-abs/archrelease:12
msgid "Option requires an argument -- '%s'"
msgstr "Las opciones requieren un argumento -- '%s'"
diff --git a/po/header.po.head.in b/po/header.po.head.in
new file mode 100644
index 0000000..2346080
--- /dev/null
+++ b/po/header.po.head.in
@@ -0,0 +1,14 @@
+# Copyright (C) YEAR FULL NAME
+# This file is distributed under the same license as the @PACKAGE@ package.
+#
+msgid ""
+msgstr "Project-Id-Version: @PACKAGE@ @VERSION@\n"
+ "Report-Msgid-Bugs-To: Parabola Hackers <dev@lists.parabola.nu>\n"
+ "PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
+ "Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
+ "Language-Team: LANGUAGE <MAILING_LIST@ADDRESS>\n"
+ "Language: LANGCODE\n"
+ "MIME-Version: 1.0\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Content-Transfer-Encoding: 8bit\n"
+ "Plural-Forms: nplurals=2; plural=(n != 1);\n"