summaryrefslogtreecommitdiff
path: root/rePKGBUILD.proto
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-05-29 23:19:16 -0500
committerJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-05-29 23:19:16 -0500
commit285ee68f879b655b50a7d8cb4d8c27c1fc82dd27 (patch)
treed45492c3cd14f23ece03deda2e89c6873f0479c2 /rePKGBUILD.proto
parentc7ec446aef83f99746cb6e1b8935b73e65bc0d8d (diff)
* librerepkg uses makepkg -p and source PKGBUILD
* rePKGBUILD.proto for /usr/share/pacman
Diffstat (limited to 'rePKGBUILD.proto')
-rw-r--r--rePKGBUILD.proto28
1 files changed, 28 insertions, 0 deletions
diff --git a/rePKGBUILD.proto b/rePKGBUILD.proto
new file mode 100644
index 0000000..17342ce
--- /dev/null
+++ b/rePKGBUILD.proto
@@ -0,0 +1,28 @@
+# This is an example rePKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+source PKGBUILD
+unset build package md5sums source
+_repo=
+source=(PKGBUILD
+ http://mirrors.kernel.org/archlinux/${_repo}/os/$CARCH/$pkgname-$pkgver.tar.gz
+ # files for pkg modifications
+ )
+
+build() {
+ cd "${srcdir}/"
+ rm .{INSTALL,PKGINFO} $_pkgbase-$pkgver-$_pkgrel-$CARCH.pkg.tar.xz
+ # actions for package modifications
+ # be sure to remove source files
+}
+
+package() {
+ cd ${srcdir}
+ cp -a ./* ${pkgdir}
+}
+
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file