summaryrefslogtreecommitdiff
path: root/src/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
commit7e704d7ac997387341e920e1757c24cac0efe5e9 (patch)
treea9f30eabaaad5496397a91053d3e03bab1ea57e4 /src/Makefile
parent7785a72495e3eb0ea826b41720c241f58a15b601 (diff)
Refactor the build system. Avoid recursive make.
This looks like a lot, but more things should "just work". We have `make dist` now!
Diffstat (limited to 'src/Makefile')
-rw-r--r--src/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/Makefile b/src/Makefile
index 63f7782..8fbe735 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -1,2 +1,7 @@
-pkgconfdir=$(sysconfdir)
-include ../common.mk
+include $(dir $(lastword $(MAKEFILE_LIST)))/../config.mk
+include $(topsrcdir)/automake.head.mk
+pkgconfdir = $(sysconfdir)
+
+am_subdirs = abslibre-tools chroot-tools devtools gitget lib librefetch toru xbs xbs-abs xbs-abslibre
+
+include $(topsrcdir)/automake.tail.mk