summaryrefslogtreecommitdiff
path: root/src/abslibre-tools/abslibre-commit
diff options
context:
space:
mode:
authorJoshua I. Haase H. (xihh) <hahj87@gmail.com>2012-12-04 21:19:22 -0600
committerJoshua I. Haase H. (xihh) <hahj87@gmail.com>2012-12-04 21:19:22 -0600
commitacc2c792c423c5aa81aa95f0516de7724dba3ab9 (patch)
tree73cacea8eff5cdfd23f42b740597b5498d152509 /src/abslibre-tools/abslibre-commit
parentd11741d73bbf6940c45ee0f2cadea980e9e40785 (diff)
parent098d7430e6447c4658704c3bcf88ea1ed7a5206b (diff)
Merge branch 'master' of gitpar:libretools
Conflicts: librechroot libremakepkg
Diffstat (limited to 'src/abslibre-tools/abslibre-commit')
-rwxr-xr-xsrc/abslibre-tools/abslibre-commit36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/abslibre-tools/abslibre-commit b/src/abslibre-tools/abslibre-commit
new file mode 100755
index 0000000..e906fbd
--- /dev/null
+++ b/src/abslibre-tools/abslibre-commit
@@ -0,0 +1,36 @@
+#!/bin/bash
+# ABSLibreCommit
+# Commits a PKGBUILD to ABSLibre.git
+
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+for _pkg in ${@}; do
+ [[ ! -e ${_pkg}/PKGBUILD ]] && continue
+
+ unset pkgbase pkgname
+ source ${_pkg}/PKGBUILD
+
+# use . instead of * will use .gitignore
+ git stage ${_pkg}/.
+
+ git commit -m "${pkgbase:-$pkgname}-${pkgver}-${pkgrel}"
+done
+
+exit 0