summaryrefslogtreecommitdiff
path: root/src/abslibre-tools/abslibre-commit
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-12-22 00:52:45 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-12-22 00:52:45 -0500
commitfb9764b5beddec555a4ef7dcad09e07af1b18900 (patch)
tree1e0e9116af893b33b87112300546b060c6b519f0 /src/abslibre-tools/abslibre-commit
parent116d2c3c013c098da3919937c6ce5158ff357946 (diff)
abslibre-tools: remove shallow git wrappers
Diffstat (limited to 'src/abslibre-tools/abslibre-commit')
-rwxr-xr-xsrc/abslibre-tools/abslibre-commit36
1 files changed, 0 insertions, 36 deletions
diff --git a/src/abslibre-tools/abslibre-commit b/src/abslibre-tools/abslibre-commit
deleted file mode 100755
index e906fbd..0000000
--- a/src/abslibre-tools/abslibre-commit
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/bash
-# ABSLibreCommit
-# Commits a PKGBUILD to ABSLibre.git
-
-# Copyright 2010 Nicolás Reynolds
-
-# ---------- GNU General Public License 3 ----------
-
-# This file is part of Parabola.
-
-# Parabola is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-
-# Parabola is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-
-# You should have received a copy of the GNU General Public License
-# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-
-for _pkg in ${@}; do
- [[ ! -e ${_pkg}/PKGBUILD ]] && continue
-
- unset pkgbase pkgname
- source ${_pkg}/PKGBUILD
-
-# use . instead of * will use .gitignore
- git stage ${_pkg}/.
-
- git commit -m "${pkgbase:-$pkgname}-${pkgver}-${pkgrel}"
-done
-
-exit 0