summaryrefslogtreecommitdiff
path: root/src/abslibre-tools/abslibre-commit
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-07 00:17:08 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-07 00:17:08 -0500
commite9bc885c355babf7851de31db8e1920dde752993 (patch)
treefd39b7d6401ead53942f66bfc4219a06f386a23f /src/abslibre-tools/abslibre-commit
parentc74d072dc83c5e3b3d9462678884cd0411a7d1d0 (diff)
organize the files
Diffstat (limited to 'src/abslibre-tools/abslibre-commit')
-rwxr-xr-xsrc/abslibre-tools/abslibre-commit36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/abslibre-tools/abslibre-commit b/src/abslibre-tools/abslibre-commit
new file mode 100755
index 0000000..e906fbd
--- /dev/null
+++ b/src/abslibre-tools/abslibre-commit
@@ -0,0 +1,36 @@
+#!/bin/bash
+# ABSLibreCommit
+# Commits a PKGBUILD to ABSLibre.git
+
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+for _pkg in ${@}; do
+ [[ ! -e ${_pkg}/PKGBUILD ]] && continue
+
+ unset pkgbase pkgname
+ source ${_pkg}/PKGBUILD
+
+# use . instead of * will use .gitignore
+ git stage ${_pkg}/.
+
+ git commit -m "${pkgbase:-$pkgname}-${pkgver}-${pkgrel}"
+done
+
+exit 0