summaryrefslogtreecommitdiff
path: root/src/abslibre-tools/librestage
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-31 18:52:49 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:53:19 -0600
commit1316ba7aa96c69ea541f1b7b3715aad5d1c8eb14 (patch)
treedf265c278a4bcb4823a725b9d78936d6f6fc67ef /src/abslibre-tools/librestage
parent29230b22081f9982f02d1c2fa46834089422d098 (diff)
[all tools]: use conf.sh (and libremessages if necessary)
Diffstat (limited to 'src/abslibre-tools/librestage')
-rwxr-xr-xsrc/abslibre-tools/librestage10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/abslibre-tools/librestage b/src/abslibre-tools/librestage
index ae66cce..c0936cc 100755
--- a/src/abslibre-tools/librestage
+++ b/src/abslibre-tools/librestage
@@ -22,9 +22,10 @@
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-source /etc/libretools.conf
-custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
-[[ -e $custom_config ]] && source $custom_config
+. libremessages
+. $(librelib conf.sh)
+load_files libretools
+check_vars libretools ARCHES WORKDIR || exit 1
if [ -w / ]; then
error "This script should be run as regular user"
@@ -68,8 +69,7 @@ fi
}
# Source the needed files
-source /etc/makepkg.conf
-[[ -e ~/.makepkg.conf ]] && source ~/.makepkg.conf
+load_files makepkg
source ./PKGBUILD
[[ -e ./rePKGBUILD ]] && source ./rePKGBUILD